summaryrefslogtreecommitdiff
path: root/net-misc/chrony/chrony-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild60
1 files changed, 31 insertions, 29 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 0338e59678bc..8ff387f448ec 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -18,21 +18,15 @@ fi
LICENSE="GPL-2"
SLOT="0"
-
IUSE="
- +adns +caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps readline +refclock +rtc
- +seccomp +sechash selinux
+ +caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps readline +refclock
+ +rtc samba +seccomp +sechash selinux
"
-
REQUIRED_USE="
?? ( libedit readline )
sechash? ( nettle )
"
-
RESTRICT=test
-
-BDEPEND=""
-
CDEPEND="
caps? ( acct-group/ntp acct-user/ntp sys-libs/libcap )
libedit? ( dev-libs/libedit )
@@ -40,28 +34,27 @@ CDEPEND="
readline? ( >=sys-libs/readline-4.1-r4:= )
seccomp? ( sys-libs/libseccomp )
"
-
DEPEND="
${CDEPEND}
html? ( dev-ruby/asciidoctor )
pps? ( net-misc/pps-tools )
"
-
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-chronyd )
"
-
-if [[ ${PV} == "9999" ]]; then
- BDEPEND+=" virtual/w3m"
-fi
-
-S="${WORKDIR}/${P/_/-}"
-
+BDEPEND="
+ nettle? ( virtual/pkgconfig )
+"
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
)
+S="${WORKDIR}/${P/_/-}"
+
+if [[ ${PV} == "9999" ]]; then
+ BDEPEND+=" virtual/w3m"
+fi
src_prepare() {
default
@@ -70,11 +63,19 @@ src_prepare() {
-e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
doc/* examples/* || die
- # Copy for potential user fixup
- cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
- cp examples/chronyd.service "${T}"/chronyd.service
+ sed -i \
+ -e 's|RELOADDNS||g' \
+ -e 's|pkg-config|${PKG_CONFIG}|g' \
+ configure || die
- # Set config for privdrop
+ sed \
+ -e 's/-F 1/-F 0/' \
+ examples/chronyd.service > "${T}"/chronyd.service || die
+
+ cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf || die
+}
+
+src_configure() {
if ! use caps; then
sed -i \
-e 's/-u ntp//' \
@@ -83,13 +84,11 @@ src_prepare() {
if ! use seccomp; then
sed -i \
- -e 's/-F 1//' \
+ -e 's/-F 0//' \
"${T}"/chronyd.conf "${T}"/chronyd.service || die
fi
-}
-src_configure() {
- tc-export CC
+ tc-export CC PKG_CONFIG
local CHRONY_EDITLINE
# ./configure legend:
@@ -103,10 +102,11 @@ src_configure() {
CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
fi
+ # Note: ncurses and nss switches are mentioned in the configure script but
+ # do nothing
# not an autotools generated script
local myconf=(
$(use_enable seccomp scfilter)
- $(usex adns '' --disable-asyncdns)
$(usex caps '' --disable-linuxcaps)
$(usex cmdmon '' --disable-cmdmon)
$(usex ipv6 '' --disable-ipv6)
@@ -116,6 +116,7 @@ src_configure() {
$(usex pps '' --disable-pps)
$(usex refclock '' --disable-refclock)
$(usex rtc '' --disable-rtc)
+ $(usex samba --enable-ntp-signd '')
$(usex sechash '' --disable-sechash)
${CHRONY_EDITLINE}
${EXTRA_ECONF}
@@ -124,14 +125,15 @@ src_configure() {
--mandir="${EPREFIX}/usr/share/man"
--prefix="${EPREFIX}/usr"
--sysconfdir="${EPREFIX}/etc/chrony"
+ --with-hwclockfile="${EPREFIX}/etc/adjtime"
--with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
--without-nss
--without-tomcrypt
)
- # print the ./configure call to aid in future debugging
- echo bash ./configure "${myconf[@]}" >&2
- bash ./configure "${myconf[@]}" || die
+ # print the ./configure call
+ echo sh ./configure "${myconf[@]}" >&2
+ sh ./configure "${myconf[@]}" || die
}
src_compile() {