summaryrefslogtreecommitdiff
path: root/net-misc/chrony/chrony-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild78
1 files changed, 64 insertions, 14 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 543cabf61d5c..0338e59678bc 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -2,40 +2,60 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 tmpfiles systemd toolchain-funcs
+inherit systemd tmpfiles toolchain-funcs
DESCRIPTION="NTP client and server programs"
HOMEPAGE="https://chrony.tuxfamily.org/"
-EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
+
+ inherit git-r3
+else
+ SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="
- +adns +caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc
- +seccomp selinux
+ +adns +caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps readline +refclock +rtc
+ +seccomp +sechash selinux
"
+
REQUIRED_USE="
?? ( libedit readline )
+ sechash? ( nettle )
"
+RESTRICT=test
+
+BDEPEND=""
+
CDEPEND="
- caps? ( sys-libs/libcap )
+ caps? ( acct-group/ntp acct-user/ntp sys-libs/libcap )
libedit? ( dev-libs/libedit )
+ nettle? ( dev-libs/nettle:= )
readline? ( >=sys-libs/readline-4.1-r4:= )
seccomp? ( sys-libs/libseccomp )
"
+
DEPEND="
${CDEPEND}
- caps? ( acct-group/ntp acct-user/ntp )
- dev-ruby/asciidoctor
+ html? ( dev-ruby/asciidoctor )
pps? ( net-misc/pps-tools )
"
+
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-chronyd )
"
-RESTRICT=test
+
+if [[ ${PV} == "9999" ]]; then
+ BDEPEND+=" virtual/w3m"
+fi
+
S="${WORKDIR}/${P/_/-}"
PATCHES=(
@@ -45,12 +65,13 @@ PATCHES=(
src_prepare() {
default
+
sed -i \
-e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
doc/* examples/* || die
# Copy for potential user fixup
- cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+ cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
cp examples/chronyd.service "${T}"/chronyd.service
# Set config for privdrop
@@ -89,15 +110,16 @@ src_configure() {
$(usex caps '' --disable-linuxcaps)
$(usex cmdmon '' --disable-cmdmon)
$(usex ipv6 '' --disable-ipv6)
+ $(usex nettle '' --without-nettle)
$(usex ntp '' --disable-ntp)
$(usex phc '' --disable-phc)
$(usex pps '' --disable-pps)
$(usex refclock '' --disable-refclock)
$(usex rtc '' --disable-rtc)
+ $(usex sechash '' --disable-sechash)
${CHRONY_EDITLINE}
${EXTRA_ECONF}
--chronysockdir="${EPREFIX}/run/chrony"
- --disable-sechash
--docdir="${EPREFIX}/usr/share/doc/${PF}"
--mandir="${EPREFIX}/usr/share/man"
--prefix="${EPREFIX}/usr"
@@ -113,7 +135,12 @@ src_configure() {
}
src_compile() {
- emake all docs
+ if [[ ${PV} == "9999" ]]; then
+ # uses w3m
+ emake -C doc man txt
+ fi
+
+ emake all docs $(usex html '' 'ADOC=true')
}
src_install() {
@@ -130,11 +157,20 @@ src_install() {
newtmpfiles - chronyd.conf <<<"d /run/chrony 0750 $(usex caps 'ntp ntp' 'root root')"
- docinto html
- dodoc doc/*.html
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
keepdir /var/{lib,log}/chrony
+ if use caps; then
+ # Prepare a directory for the chrony.drift file (a la ntpsec)
+ # Ensures the environment is sane on new installs
+ fowners ntp:ntp /var/{lib,log}/chrony
+ fperms 770 /var/lib/chrony
+ fi
+
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
@@ -143,6 +179,20 @@ src_install() {
systemd_enable_ntpunit 50-chrony chronyd.service
}
+pkg_preinst() {
+ HAD_CAPS=false
+
+ if has_version 'net-misc/chrony[caps]'; then
+ HAD_CAPS=true
+ fi
+}
+
pkg_postinst() {
tmpfiles_process chronyd.conf
+
+ if [[ -n ${REPLACING_VERSIONS} ]] && use caps && ! ${HAD_CAPS}; then
+ ewarn "Please adjust permissions on ${EROOT}/var/{lib,log}/chrony to be owned by ntp:ntp"
+ ewarn "e.g. chown -R ntp:ntp ${EROOT}/var/{lib,log}/chrony"
+ ewarn "This is necessary for chrony to drop privileges"
+ fi
}