summaryrefslogtreecommitdiff
path: root/net-misc/cfengine/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cfengine/files')
-rw-r--r--net-misc/cfengine/files/511666-segfault.patch20
-rw-r--r--net-misc/cfengine/files/admit-noclass-520696.patch15
-rw-r--r--net-misc/cfengine/files/cf-execd.rc618
-rw-r--r--net-misc/cfengine/files/cf-monitord.rc617
-rw-r--r--net-misc/cfengine/files/cf-serverd.rc617
-rw-r--r--net-misc/cfengine/files/cfengine-2.2.10-snprintf_buffer_overflow.patch11
-rw-r--r--net-misc/cfengine/files/cfengine-3.4.5-acl.patch30
-rw-r--r--net-misc/cfengine/files/cfengine-3.4.5-ifconfig.patch42
-rw-r--r--net-misc/cfengine/files/cfengine-3.5.3-ifconfig.patch42
-rw-r--r--net-misc/cfengine/files/cfengine-3.6.2-ifconfig.patch11
-rw-r--r--net-misc/cfengine/files/cfenvd.rc617
-rw-r--r--net-misc/cfengine/files/cfexecd.rc617
-rw-r--r--net-misc/cfengine/files/cfservd.rc617
13 files changed, 274 insertions, 0 deletions
diff --git a/net-misc/cfengine/files/511666-segfault.patch b/net-misc/cfengine/files/511666-segfault.patch
new file mode 100644
index 000000000000..ea3ae9686254
--- /dev/null
+++ b/net-misc/cfengine/files/511666-segfault.patch
@@ -0,0 +1,20 @@
+Fix a bug involving CheckFriendReliability (see bug #482439)
+
+Index: cfengine2-2.2.9/src/instrument.c
+===================================================================
+--- cfengine2-2.2.9.orig/src/instrument.c 2009-03-06 21:25:59.000000000 +0000
++++ cfengine2-2.2.9/src/instrument.c 2009-03-06 21:26:31.000000000 +0000
+@@ -716,11 +716,11 @@
+ key.data = timekey;
+ key.size = strlen(timekey)+1;
+
+- if ((errno = dbp->get(dbp,NULL,&key,&value,0)) != 0)
++ if ((errno = dbpent->get(dbpent,NULL,&key,&value,0)) != 0)
+ {
+ if (errno != DB_NOTFOUND)
+ {
+- dbp->err(dbp,errno,NULL);
++ dbpent->err(dbpent,errno,NULL);
+ exit(1);
+ }
+ }
diff --git a/net-misc/cfengine/files/admit-noclass-520696.patch b/net-misc/cfengine/files/admit-noclass-520696.patch
new file mode 100644
index 000000000000..1e5d8594aaed
--- /dev/null
+++ b/net-misc/cfengine/files/admit-noclass-520696.patch
@@ -0,0 +1,15 @@
+Fix a bug with admit/grant that let cfengine2 fails when the class
+of a cfengine fragment does not exist and more than a host or IP
+ranges are specified for a path (see #520696)
+
+--- a/src/install.c
++++ b/src/install.c
+@@ -6561,7 +6561,7 @@
+ if (!IsDefinedClass(classes))
+ {
+ Debug1("Not installing Auth path, no match\n");
+- InitializeAction();
++// InitializeAction();
+ return;
+ }
+
diff --git a/net-misc/cfengine/files/cf-execd.rc6 b/net-misc/cfengine/files/cf-execd.rc6
new file mode 100644
index 000000000000..8c3936d8a718
--- /dev/null
+++ b/net-misc/cfengine/files/cf-execd.rc6
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+ after cf-serverd
+}
+
+start() {
+ ebegin "Starting cf-execd"
+ start-stop-daemon --start --exec /usr/sbin/cf-execd -- ${EXTRA_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cf-execd"
+ start-stop-daemon --stop --pidfile /var/cfengine/cf-execd.pid --exec /usr/sbin/cf-execd
+ eend $?
+}
diff --git a/net-misc/cfengine/files/cf-monitord.rc6 b/net-misc/cfengine/files/cf-monitord.rc6
new file mode 100644
index 000000000000..6f985a62b020
--- /dev/null
+++ b/net-misc/cfengine/files/cf-monitord.rc6
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cf-monitord"
+ start-stop-daemon --start --exec /usr/sbin/cf-monitord -- ${EXTRA_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cf-monitord"
+ start-stop-daemon --stop --pidfile /var/cfengine/cf-monitord.pid --exec /usr/sbin/cf-monitord
+ eend $?
+}
diff --git a/net-misc/cfengine/files/cf-serverd.rc6 b/net-misc/cfengine/files/cf-serverd.rc6
new file mode 100644
index 000000000000..d73e2bc2c729
--- /dev/null
+++ b/net-misc/cfengine/files/cf-serverd.rc6
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cf-serverd"
+ start-stop-daemon --start --exec /usr/sbin/cf-serverd -- ${EXTRA_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cf-serverd"
+ start-stop-daemon --stop --pidfile /var/cfengine/cf-serverd.pid --exec /usr/sbin/cf-serverd
+ eend $?
+}
diff --git a/net-misc/cfengine/files/cfengine-2.2.10-snprintf_buffer_overflow.patch b/net-misc/cfengine/files/cfengine-2.2.10-snprintf_buffer_overflow.patch
new file mode 100644
index 000000000000..dee9b797f6ac
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-2.2.10-snprintf_buffer_overflow.patch
@@ -0,0 +1,11 @@
+--- src/instrument.c.old 2010-10-15 22:20:58.014091858 +0200
++++ src/instrument.c 2010-10-15 22:21:34.132271440 +0200
+@@ -542,7 +542,7 @@ while (dbcp->c_get(dbcp, &key, &value, D
+
+ tthen = (time_t)then;
+
+- snprintf(datebuf,CF_BUFSIZE-1,"%s",ctime(&tthen));
++ snprintf(datebuf,CF_MAXVARSIZE-1,"%s",ctime(&tthen));
+ datebuf[strlen(datebuf)-9] = '\0'; /* Chop off second and year */
+
+ snprintf(addr,15,"%s",hostname+1);
diff --git a/net-misc/cfengine/files/cfengine-3.4.5-acl.patch b/net-misc/cfengine/files/cfengine-3.4.5-acl.patch
new file mode 100644
index 000000000000..815f257c36fa
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.4.5-acl.patch
@@ -0,0 +1,30 @@
+From a12b5b3b8cd4397545104923d1de3297fd971f9e Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Fri, 29 Mar 2013 00:23:21 +0100
+Subject: [PATCH] Fix acl header detection
+
+
+Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
+---
+ configure.ac | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 542d115..f3f0c04 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -335,7 +335,10 @@ AC_ARG_WITH([libacl],
+ if test "x$with_libacl" != xno; then
+ CF3_WITH_LIBRARY(libacl, [
+ AC_CHECK_LIB(acl, acl_init, [], [if test "x$with_libacl" != xcheck; then AC_MSG_ERROR(Cannot find libacl library); fi])
+- AC_CHECK_HEADERS([acl.h sys/acl.h acl/libacl.h], [], [if test "x$with_libacl" != xcheck; then AC_MSG_ERROR(Cannot find libacl library headers); fi])
++ AC_CHECK_HEADERS([acl.h sys/acl.h acl/libacl.h], [found_acl_h=yes], [])
++ if test "x$found_acl_h" != xyes; then
++ AC_MSG_ERROR(Cannot find libacl library headers)
++ fi
+ ])
+ fi
+
+--
+1.8.1.5
+
diff --git a/net-misc/cfengine/files/cfengine-3.4.5-ifconfig.patch b/net-misc/cfengine/files/cfengine-3.4.5-ifconfig.patch
new file mode 100644
index 000000000000..47107784ce0f
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.4.5-ifconfig.patch
@@ -0,0 +1,42 @@
+Patch by clabbe.montjoie@gmail.com
+https://bugs.gentoo.org/444532
+
+--- src/conf.h.in.old 2012-12-28 16:18:23.000000000 +0100
++++ src/conf.h.in 2012-12-28 16:19:08.000000000 +0100
+@@ -773,3 +773,6 @@
+
+ /* Define to rpl_vsnprintf if the replacement function should be used. */
+ #undef vsnprintf
++
++/* Define to the path for running ifconfig -a */
++#undef IFCONFIG_RUN
+--- src/unix.c.old 2012-12-28 16:05:28.000000000 +0100
++++ src/unix.c 2012-12-28 16:13:15.000000000 +0100
+@@ -900,7 +900,7 @@
+
+ default:
+
+- if ((pp = cf_popen("/sbin/ifconfig -a", "r")) == NULL)
++ if ((pp = cf_popen(IFCONFIG_RUN, "r")) == NULL)
+ {
+ CfOut(cf_verbose, "", "Could not find interface info\n");
+ return;
+--- configure.ac.old 2012-12-29 11:38:20.000000000 +0100
++++ configure.ac 2012-12-29 11:49:11.000000000 +0100
+@@ -882,6 +882,16 @@
+
+
+ dnl ######################################################################
++dnl Find the path to ifconfig
++dnl ######################################################################
++
++AC_PATH_PROG(IFCONFIG_PATH,ifconfig)
++if test x"$IFCONFIG_PATH" = x"" ; then
++ AC_MSG_ERROR([Cannot found the ifconfig binary.])
++fi
++AC_DEFINE_UNQUOTED(IFCONFIG_RUN, "$IFCONFIG_PATH -a", [the path to run ifconfig -a])
++
++dnl ######################################################################
+ dnl Summarize
+ dnl ######################################################################
+
diff --git a/net-misc/cfengine/files/cfengine-3.5.3-ifconfig.patch b/net-misc/cfengine/files/cfengine-3.5.3-ifconfig.patch
new file mode 100644
index 000000000000..dc982c6801f7
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.5.3-ifconfig.patch
@@ -0,0 +1,42 @@
+diff -ur cfengine-3.5.3.orig/configure.ac cfengine-3.5.3/configure.ac
+--- cfengine-3.5.3.orig/configure.ac 2013-12-09 13:13:14.000000000 +0100
++++ cfengine-3.5.3/configure.ac 2014-02-27 12:36:55.179893570 +0100
+@@ -1047,6 +1047,16 @@
+ AM_SUBST_NOTMAKE(post_macros)
+
+ dnl ######################################################################
++dnl Find the path to ifconfig
++dnl ######################################################################
++
++AC_PATH_PROG(IFCONFIG_PATH,ifconfig)
++if test x"$IFCONFIG_PATH" = x"" ; then
++ AC_MSG_ERROR([Cannot found the ifconfig binary.])
++fi
++AC_DEFINE_UNQUOTED(IFCONFIG_RUN, "$IFCONFIG_PATH -a", [the path to run ifconfig -a])
++
++dnl ######################################################################
+ dnl Summarize
+ dnl ######################################################################
+
+diff -ur cfengine-3.5.3.orig/libpromises/unix.c cfengine-3.5.3/libpromises/unix.c
+--- cfengine-3.5.3.orig/libpromises/unix.c 2013-12-09 13:13:14.000000000 +0100
++++ cfengine-3.5.3/libpromises/unix.c 2014-02-27 12:38:35.036608105 +0100
+@@ -767,7 +767,7 @@
+ return;
+ }
+ #else
+- if ((pp = cf_popen("/sbin/ifconfig -a", "r", true)) == NULL)
++ if ((pp = cf_popen(IFCONFIG_RUN, "r", true)) == NULL)
+ {
+ Log(LOG_LEVEL_VERBOSE, "Could not find interface info");
+ return;
+diff -ur cfengine-3.5.3.orig/libutils/config.h.in cfengine-3.5.3/libutils/config.h.in
+--- cfengine-3.5.3.orig/libutils/config.h.in 2013-12-09 13:55:25.000000000 +0100
++++ cfengine-3.5.3/libutils/config.h.in 2014-02-27 12:39:41.537416111 +0100
+@@ -914,3 +914,6 @@
+
+ /* Define to rpl_vsnprintf if the replacement function should be used. */
+ #undef vsnprintf
++
++/* Define to the path for running ifconfig -a */
++#undef IFCONFIG_RUN
diff --git a/net-misc/cfengine/files/cfengine-3.6.2-ifconfig.patch b/net-misc/cfengine/files/cfengine-3.6.2-ifconfig.patch
new file mode 100644
index 000000000000..ae0f491347f9
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.6.2-ifconfig.patch
@@ -0,0 +1,11 @@
+--- cfengine-3.6.2.orig/libenv/unix_iface.c 2014-09-25 07:53:31.000000000 -0400
++++ cfengine-3.6.2/libenv/unix_iface.c 2014-11-26 23:55:20.151351070 -0500
+@@ -625,7 +625,7 @@
+ return;
+ }
+ #else
+- if ((pp = cf_popen("/sbin/ifconfig -a", "r", true)) == NULL)
++ if ((pp = cf_popen("/sbin/ifconfig -a", "r", true)) == NULL || (pp = cf_popen("/bin/ifconfig -a", "r", true)) == NULL)
+ {
+ Log(LOG_LEVEL_VERBOSE, "Could not find interface info");
+ return;
diff --git a/net-misc/cfengine/files/cfenvd.rc6 b/net-misc/cfengine/files/cfenvd.rc6
new file mode 100644
index 000000000000..638ae993dcf5
--- /dev/null
+++ b/net-misc/cfengine/files/cfenvd.rc6
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cfenvd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/cfenvd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cfenvd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/cfenvd
+ eend $?
+}
diff --git a/net-misc/cfengine/files/cfexecd.rc6 b/net-misc/cfengine/files/cfexecd.rc6
new file mode 100644
index 000000000000..032a9c469b50
--- /dev/null
+++ b/net-misc/cfengine/files/cfexecd.rc6
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cfexecd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/cfexecd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cfexecd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/cfexecd
+ eend $?
+}
diff --git a/net-misc/cfengine/files/cfservd.rc6 b/net-misc/cfengine/files/cfservd.rc6
new file mode 100644
index 000000000000..034b25c72000
--- /dev/null
+++ b/net-misc/cfengine/files/cfservd.rc6
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cfservd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/cfservd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cfservd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/cfservd
+ eend $?
+}