summaryrefslogtreecommitdiff
path: root/net-misc/bird/bird-2.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/bird/bird-2.0.12.ebuild')
-rw-r--r--net-misc/bird/bird-2.0.12.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/bird/bird-2.0.12.ebuild b/net-misc/bird/bird-2.0.12.ebuild
index 11b8c7484e39..043f67e052c9 100644
--- a/net-misc/bird/bird-2.0.12.ebuild
+++ b/net-misc/bird/bird-2.0.12.ebuild
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~x64-macos"
-IUSE="+client debug libssh"
+IUSE="+client custom-cflags debug libssh"
RDEPEND="
client? (
@@ -56,6 +56,12 @@ src_configure() {
$(use_enable libssh)
)
+ # lto must be enabled by default as bird is mono-threaded and use several
+ # optimisations to be fast, as it may very likely be exposed to several
+ # thounsand BGP updates per seconds
+ # Although, we make it possible to deactivate it if wanted
+ use custom-cflags && myargs+=( bird_cv_c_lto=no )
+
econf "${myargs[@]}"
}