summaryrefslogtreecommitdiff
path: root/net-misc/asterisk/files/asterisk-historic-uclibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/asterisk/files/asterisk-historic-uclibc.patch')
-rw-r--r--net-misc/asterisk/files/asterisk-historic-uclibc.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/asterisk/files/asterisk-historic-uclibc.patch b/net-misc/asterisk/files/asterisk-historic-uclibc.patch
new file mode 100644
index 000000000000..167ae080b193
--- /dev/null
+++ b/net-misc/asterisk/files/asterisk-historic-uclibc.patch
@@ -0,0 +1,23 @@
+Gentoo bug 66557
+Link: http://bugs.gentoo.org/show_bug.cgi?id=66557
+Patch-By: REdOG
+
+Submitted upstream: No
+
+The uclibc environment, as opposed to the glibc environment, needs explicit
+linking with the pthread & dl libraries. Without these, name resolution is
+not functional.
+
+--- asterisk-1.8.7.0-rc2.orig/Makefile 2011-08-25 21:00:55.000000000 +0200
++++ asterisk-1.8.7.0-rc2.orig/Makefile 2011-09-21 14:13:12.823076046 +0200
+@@ -247,6 +247,10 @@
+ _ASTCFLAGS+=-pthread -ftrampolines
+ endif
+
++ifeq ($(OSARCH),linux-uclibc)
++ AST_LIBS+=-lpthread -ldl
++endif
++
+ ifeq ($(OSARCH),SunOS)
+ _ASTCFLAGS+=-Wcast-align -DSOLARIS -I../include/solaris-compat -I/opt/ssl/include -I/usr/local/ssl/include -D_XPG4_2 -D__EXTENSIONS__
+ endif