summaryrefslogtreecommitdiff
path: root/net-mail/up-imapproxy/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/up-imapproxy/files')
-rw-r--r--net-mail/up-imapproxy/files/imapproxy.initd20
-rw-r--r--net-mail/up-imapproxy/files/imapproxyd.864
-rw-r--r--net-mail/up-imapproxy/files/pimpstat.827
-rw-r--r--net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch19
-rw-r--r--net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch20
5 files changed, 150 insertions, 0 deletions
diff --git a/net-mail/up-imapproxy/files/imapproxy.initd b/net-mail/up-imapproxy/files/imapproxy.initd
new file mode 100644
index 000000000000..a95389027452
--- /dev/null
+++ b/net-mail/up-imapproxy/files/imapproxy.initd
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use logger
+ need net
+}
+
+start() {
+ ebegin "Starting up-imapproxy"
+ start-stop-daemon --start --quiet --exec /usr/sbin/imapproxyd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping up-imapproxy"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/imapproxyd
+ eend $?
+}
diff --git a/net-mail/up-imapproxy/files/imapproxyd.8 b/net-mail/up-imapproxy/files/imapproxyd.8
new file mode 100644
index 000000000000..1c70d9525756
--- /dev/null
+++ b/net-mail/up-imapproxy/files/imapproxyd.8
@@ -0,0 +1,64 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH IMAPPROXYD 8 "Mar 12, 2004" "Dave McMurtrie" "IMAP proxy daemon"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.SH NAME
+.B imapproxyd
+\- IMAP proxy daemon
+.SH SYNOPSIS
+.B imapproxyd
+.RI
+[
+.B -f
+.RI
+<config file name> ]
+.RI
+[
+.B -p
+.RI
+<pidfile name> ]
+.br
+.SH DESCRIPTION
+This manual page documents briefly the
+.B imapproxyd
+command.
+This manual page was written for the Debian distribution
+because the original program does not have a manual page.
+.PP
+UP-ImapProxy proxies IMAP transactions between an IMAP client and an IMAP
+server. The general idea is that the client should never know that it is
+not talking to the real IMAP server, but ImapProxy caches server connections.
+.PP
+ImapProxy was written to compensate for webmail clients that are unable to
+maintain persistent connections to an IMAP server. Most webmail clients
+need to log in to an IMAP server for nearly every single transaction; This
+behaviour can cause tragic performance problems on the IMAP server.
+ImapProxy tries to deal with this problem by leaving server connections
+open for a short time after a webmail client logs out. When the webmail
+client connects again, ImapProxy will determine if there is a cached
+connection available and reuse it if possible.
+.BR
+.SH FILES
+By default, UP-ImapProxy reads /etc/imapproxy.conf on startup.
+This can be changed by using the
+.I -f
+option
+.PP
+Unless foreground_mode has been enabled, UP-ImapProxy will write its PID to to
+a PID-file. It defaults to /var/run/imapproxy.pid, but can be overridden with
+the
+.I -p
+option
+.SH SEE ALSO
+.BR pimpstat (8),
+.br
+.SH AUTHOR
+This manual page was written by Jose Luis Tallon
+.nh
+<jltallon@adv-solutions.net>,
+for the Debian GNU/Linux system (but may be used by others).
+
+
diff --git a/net-mail/up-imapproxy/files/pimpstat.8 b/net-mail/up-imapproxy/files/pimpstat.8
new file mode 100644
index 000000000000..2466e7ce2780
--- /dev/null
+++ b/net-mail/up-imapproxy/files/pimpstat.8
@@ -0,0 +1,27 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH PIMPSTATS 8 "Mar 12, 2004" "Dave McMurtrie" "IMAP proxy daemon"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.SH NAME
+ pimpstat \- UP-ImapProxy statistics
+.SH SYNOPSIS
+.B pimpstat
+.RI [options]
+.br
+.SH DESCRIPTION
+This manual page documents briefly the
+.B pimpstat
+command.
+This manual page was written for the Debian distribution
+because the original program does not have a manual page.
+.SH SEE ALSO
+.BR imapproxyd (8),
+.br
+.SH AUTHOR
+This manual page was written by Jose Luis Tallon
+.nh
+<jltallon@adv-solutions.net>,
+for the Debian GNU/Linux system (but may be used by others).
diff --git a/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch
new file mode 100644
index 000000000000..4ba1b6b725e5
--- /dev/null
+++ b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch
@@ -0,0 +1,19 @@
+commit 98876519b581c0427b81d772f56b25ad3d0121df
+Author: Eray Aslan <eras@gentoo.org>
+Date: Sun Jun 5 19:43:41 2011 +0300
+
+ respect LDFLAGS
+
+diff --git a/Makefile.in b/Makefile.in
+index 1b235b8..8ac1e4f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -70,7 +70,7 @@ $(XYD_BIN): $(XYD_OBJ)
+ $(CC) -o $@ $(XYD_OBJ) $(LDFLAGS) $(XYD_LIB)
+
+ $(TAT_BIN): $(TAT_OBJ)
+- $(CC) -o $@ $(TAT_OBJ) $(TAT_LIB)
++ $(CC) -o $@ $(TAT_OBJ) $(LDFLAGS) $(TAT_LIB)
+
+ clean:
+ rm -f ./src/core $(XYD_OBJ) $(TAT_OBJ) $(XYD_BIN) $(TAT_BIN)
diff --git a/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch
new file mode 100644
index 000000000000..cbe19e8c0eb7
--- /dev/null
+++ b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch
@@ -0,0 +1,20 @@
+--- a/configure.in
++++ b/configure.in
+@@ -121,12 +121,16 @@
+ save_LIBS="$LIBS"
+ LIB_CURSES=""
+ AC_CHECK_LIB(curses, initscr, LIB_CURSES="-lcurses", [ curses_found=no ])
+-if test "$curses_found" == no; then
++if test "$curses_found" = no; then
+ AC_CHECK_LIB(ncurses, initscr, LIB_CURSES="-lncurses",
+ AC_ERROR([Can't compile without curses!!!]))
+ fi
+
+ LIBS="$save_LIBS"
++
++AC_SEARCH_LIBS(stdscr, tinfo curses ncurses, [LIB_CURSES="$LIB_CURSES $ac_cv_search_stdscr"],
++ AC_MSG_ERROR([Cannot find a library providing stdscr]))
++
+ AC_SUBST(LIB_CURSES)
+
+