summaryrefslogtreecommitdiff
path: root/net-mail/safecat/safecat-1.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/safecat/safecat-1.13.ebuild')
-rw-r--r--net-mail/safecat/safecat-1.13.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/net-mail/safecat/safecat-1.13.ebuild b/net-mail/safecat/safecat-1.13.ebuild
deleted file mode 100644
index f8fa413f269e..000000000000
--- a/net-mail/safecat/safecat-1.13.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Safecat implements qmail's maildir algorithm, safely copying standard input"
-HOMEPAGE="http://www.jeenyus.net/linux/software/safecat.html"
-SRC_URI="http://www.jeenyus.net/linux/software/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ppc ~sparc x86"
-RESTRICT="test"
-
-DEPEND="sys-apps/groff"
-
-PATCHES=(
- # applying maildir-patch
- "${FILESDIR}"/safecat-1.11-gentoo.patch
- # Fix parallel make errors
- "${FILESDIR}"/${P}-makefile.patch
- # Fix POSIX head/tail syntax
- "${FILESDIR}"/${P}-head-tail-POSIX.patch
-)
-
-src_prepare() {
- default
-
- sed -ni '/man\|doc/!p' hier.c || die
-
- # Fix implicit decleration
- sed '/include <signal.h>/ a #include <stdlib.h>' -i safecat.c || die
-}
-
-src_configure() {
- echo "/usr" > conf-root || die
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
- echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
-}
-
-src_install() {
- echo "${D}/usr" > conf-root || die
- emake setup check
- einstalldocs
- doman maildir.1 safecat.1
-}