summaryrefslogtreecommitdiff
path: root/net-mail/mu/files/mu-1.12.0-no-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mu/files/mu-1.12.0-no-python.patch')
-rw-r--r--net-mail/mu/files/mu-1.12.0-no-python.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-mail/mu/files/mu-1.12.0-no-python.patch b/net-mail/mu/files/mu-1.12.0-no-python.patch
new file mode 100644
index 000000000000..9840da22ca33
--- /dev/null
+++ b/net-mail/mu/files/mu-1.12.0-no-python.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/925503
+
+Call coreutils date instead of a Python script.
+--- a/meson.build
++++ b/meson.build
+@@ -104,17 +104,16 @@ cxx.check_header('charconv', required:true)
+ build_aux = join_paths(meson.current_source_dir(), 'build-aux')
+ ################################################################################
+ # derived date values (based on 'mu-date'); used in docs
+-# we can't use the 'date' because MacOS 'date' is incompatible with GNU's.
+-pdate=find_program(join_paths(build_aux, 'date.py'))
++date=find_program('date', required:true)
+ env = environment()
+ env.set('LANG', 'C')
+-mu_day_month_year = run_command(pdate, mu_date, '%d %B %Y',
++mu_day_month_year = run_command(date, '-u', '+%d %B %Y', '--date', mu_date,
+ check:true, capture:true,
+ env: env).stdout().strip()
+-mu_month_year = run_command(pdate, mu_date, '%B %Y',
++mu_month_year = run_command(date, '-u', '+%B %Y', '--date', mu_date,
+ check:true, capture:true,
+ env: env).stdout().strip()
+-mu_year = run_command(pdate, mu_date, '%Y',
++mu_year = run_command(date, '-u', '+%Y', '--date', mu_date,
+ check:true, capture:true, env: env).stdout().strip()
+
+ ################################################################################
+--
+2.44.0
+