summaryrefslogtreecommitdiff
path: root/net-mail/mailshears/mailshears-0.0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mailshears/mailshears-0.0.4-r1.ebuild')
-rw-r--r--net-mail/mailshears/mailshears-0.0.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-mail/mailshears/mailshears-0.0.4-r1.ebuild b/net-mail/mailshears/mailshears-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..9c6e50724d69
--- /dev/null
+++ b/net-mail/mailshears/mailshears-0.0.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+# The tests are dangerous and shouldn't be run by anyone!
+# They mess with your local postgres databases.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=yard
+RUBY_FAKEGEM_EXTRADOC="doc/${PN}.example.conf.yml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mangle your mail garden"
+HOMEPAGE="http://michael.orlitzky.com/code/mailshears.xhtml"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pg-1.2 <dev-ruby/pg-2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman "doc/man1/${PN}.1"
+}