summaryrefslogtreecommitdiff
path: root/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mailbox-count/mailbox-count-0.0.8.ebuild')
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
new file mode 100644
index 000000000000..c2af7578eb1c
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="https://michael.orlitzky.com/code/mailbox-count.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-lang/ghc-9.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )"
+
+src_install() {
+ haskell-cabal_src_install
+ dodoc "${S}/doc/${PN}rc.example"
+ doman "${S}/doc/man1/${PN}.1"
+}