summaryrefslogtreecommitdiff
path: root/net-mail/automx2
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/automx2')
-rw-r--r--net-mail/automx2/Manifest3
-rw-r--r--net-mail/automx2/automx2-2021.5.ebuild46
-rw-r--r--net-mail/automx2/files/init-r126
3 files changed, 75 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index 97163393b3de..5a0ab7fc5fed 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1,6 +1,9 @@
AUX conf 721 BLAKE2B 976a2936da5e9eef71d9d08f7f12c51151549c23c27918de28da355e87e4927f84cc63904ab0feb0d10a11326ce6e44cc11531d65f6abe3d1ce213ea2e632e24 SHA512 f931acb2e5060872219709b525d64cae630062eb842e55614d57324ff5e801b4b9a99faf47c706ffe67822b29a7fb680ed59db550470afa9ded80621d4bbe3b8
AUX confd 213 BLAKE2B 2573f19bdc9022357f2f92ff17d84a1e77078c6c05a46a09b6e57ab7132d1f1078fb5003640f83213f746f94e3ab5b482b01d92feb94684665eb4e796a642841 SHA512 6c04de3ef26fd132269532c7bdca3263e95cebf5078ddd57e8ebff62229fabfb64b8ad4d988dfe99c9611c5d1081b4d3862f09d11c08aa1aabc1d5bc7c987439
AUX init 611 BLAKE2B f84cd718a1ecfe2ed36fb875bde156e6b1700da5ddd115fb841a5d8cae638369238779647c113e1fea50a36069bdb1528917b31ca93b6d8d72686eedd7315c7a SHA512 3fccc3567428e1493daabc0bae87fb769bf7d8d807775ca7d1d3d7e4fdc982b176b3985f8b3b86a1dcbcab001227c685fdba7e08a8a343a2540ee3913412c721
+AUX init-r1 608 BLAKE2B 7d2b93482c62fe0219c7194279ee495274e4b0b8319ccf2d24e7816abe7eb23452bc21c01305283deeb8224c3668641b1bd5a7f3fbf8fe783a28e58268511ace SHA512 4a1ed2c45e1414734b8e5cbb731377da2087bd4f1a1075b4acb81b5057a65c0557e9e1a05cdf6856da35067a589d9c56fcf13156e8872facfc8f161bb3cade0f
DIST automx2-2021.4.tar.gz 170903 BLAKE2B 9c8e9bc95eeac9a8a59430248d532d540e70a40c4d61f006d5d2649198e856e4b404ed75df745cfb06887c58049a9a233a597059e2f2971bf9f1c8ce65a34f3d SHA512 f306bfdca10dc884bef404e5ff24181dc9adfb8514fd0e0d984bac84ca4996f0978eda7161be46f1b3d93a9c0e61aaabdfb4b2886012570a51ad0aaf2286dd2c
+DIST automx2-2021.5.tar.gz 172317 BLAKE2B 501dea5561d780fed538676e41dac46da01bae24388f477afa66e1b27e8a271e48bd6bddc8f9a4e0f5e7b3eb9f58fca9a9b2adaf78de2f7cd2feacfc8f85c9a4 SHA512 00281f32df6b117690d9780b8a587907518e2485dc37450765c3f35acb92a27da73ecd4e35cd05e0a5307d179ba3edaa1dec80900a059c975589ae904456c565
EBUILD automx2-2021.4.ebuild 1201 BLAKE2B 757048d7aae1e660219a7ad146e258d6d59138cc71d15ddf63395f305468e3c943e2c9818d3577efa957b163beffdab8f1d16fcfcb267bc53bc83cc6687f60c5 SHA512 2c91a5c291483e62bd7e1e9ce1e67f66aaab37491313cd1f56aff426d7340b280799cbb221df2266125cbdd21685e86724d663542822fe6b659206da46b401e2
+EBUILD automx2-2021.5.ebuild 1155 BLAKE2B 5b9dc245ea033a3d7d2d29c5e09c299dd8f95bcca7cdc8287c465ee15027c00066a7e0cc49e87dd45639bf2d929e748aeabc0cddb040d1583326bb4f21b7e661 SHA512 252be12596b4616b2476f7876f0b46f7e32d95b98e8265d5d9024bd922eb3d2a1eaace554e3a1d318aa3ef44f59dcf171bf4a90d942269d45665d5fed86d392b
MISC metadata.xml 918 BLAKE2B 8f693feed959a0394e8be4a0f489c4913e142aaec8e71920fc0ace1e3ef1f8b5c79a312139bca612c3d204854f6e222252b25b1343539829f3950d1ae344483c SHA512 77e8f20c9af068189d12ba06ac566d03f8b86435b3c88682c6819975fc0636e4e427ab07b76db9d0e32a5b51b7861715c60209f6ee5ae0d4fb0a19a53c4b98a0
diff --git a/net-mail/automx2/automx2-2021.5.ebuild b/net-mail/automx2/automx2-2021.5.ebuild
new file mode 100644
index 000000000000..053aba45a4d9
--- /dev/null
+++ b/net-mail/automx2/automx2-2021.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="acct-user/automx2"
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( ${S}/docs/*.adoc ${S}/contrib/*sample.conf )
+ local HTML_DOCS=( ${S}/docs/*.{html,svg} )
+ newconfd "${FILESDIR}/confd" "${PN}"
+ newinitd "${FILESDIR}/init-r1" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/files/init-r1 b/net-mail/automx2/files/init-r1
new file mode 100644
index 000000000000..56878e8ca379
--- /dev/null
+++ b/net-mail/automx2/files/init-r1
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+: ${AUTOMX2_CONF:="/etc/${RC_SVCNAME}.conf"}
+: ${AUTOMX2_USER:="automx2"}
+: ${AUTOMX2_ARGS:="--port 4243"}
+
+command="/usr/bin/python"
+command_args="/usr/bin/flask run ${AUTOMX2_ARGS}"
+command_background="true"
+command_user="${AUTOMX2_USER}"
+pidfile="/run/${RC_SVCNAME}.pid"
+required_files="${AUTOMX2_CONF}"
+
+depend() {
+ use logger net
+ before nginx
+}
+
+start_pre() {
+ export AUTOMX2_CONF
+ export EPYTHON="python"
+ export FLASK_APP="automx2.server:app"
+ export FLASK_ENV="production"
+}