summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin32802 -> 32799 bytes
-rw-r--r--net-libs/ldns/Manifest1
-rw-r--r--net-libs/ldns/ldns-1.8.3-r1.ebuild90
3 files changed, 91 insertions, 0 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index ed15533c147f..4637afe53ba8 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index 34976ee45afb..1823eedede53 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -6,5 +6,6 @@ DIST ldns-1.8.1.tar.gz 1284971 BLAKE2B ae01ef32571fe3996ddd41f911815239abb704ea1
DIST ldns-1.8.3.tar.gz 1299856 BLAKE2B 2250445da3beec76c96fbb5cbc00f8d6a5bb6ed5867da7f23511d46ac73d6101303eb6ad85def426b7f9287f6a629a95117bcfa6eb46b775d07ed84048162c7f SHA512 c318747bd975ade389d048680b80495fb083b46507d8dcea7d4d42c75823f56a35b438dcc5320803d39583e5a1e515a51686f7f9010c061a6e8199e1a5505ae9
EBUILD ldns-1.8.0-r4.ebuild 2970 BLAKE2B daf7f3e9d06f4d45861278b75951e5eb1792f8d721229dbb343d2c6e41fe7ba28a21bea5f46a456fb94edab312a7b35a620dd115e02ecdfd59c8755a8cf23885 SHA512 05c6fdfad9784b3bd38d52bb6ac2f09617a109ddd3c24ce99ac57f5c52270da6ce229b9c1d2bb886b9109dc112a7596bb24355ced8b3f9cfb2983bd24b672f8e
EBUILD ldns-1.8.1.ebuild 1842 BLAKE2B 8ec37b4adba589508ad5ebaa4fee0c6326c6d6ee7659e46a4d41f25a69549b3ee460e78ffe24dd9e4b5c763b773100d3d871e169c0c64b08c3f2359d5e7df1d0 SHA512 c551fafcf95fbced99f02d5ae81ac5596038f51fa2dbaafedc6001369ec2d50a197e2b345ec500488b3a11f3058d3586d759b32f122cc9f8b4638fa55a23c926
+EBUILD ldns-1.8.3-r1.ebuild 1950 BLAKE2B 7ab31084b83d4973a998f38b85c7495bea28a55340d6792fc3254865ceaba51e61ed7b86a73a659c070535ede41b36dce2e5ac4152cce178b12b8be45807d8f5 SHA512 99dd8bf2a9beda73348dda98cb89dd95dae896376c741caeffb0e5b31a477764b91d3a83a2f659144c59b39be2e0921ece4e7cf155140ec79bb48341a38aa100
EBUILD ldns-1.8.3.ebuild 1949 BLAKE2B e250146286fab7c4b498288c769cbdbb7391d56aad00a1854bd73a2e35827dbd6935de52584fbf22292c878327e5eb0df7bbeef3e611ff1482b1d9d1ccd33c62 SHA512 4c6b2b302918f9ab4ed8ab6a8f5eb31feb73f153e95543fced9669836e73bc93575dc650602069594f02a45e2c50b46d098b0a7ccfd386ba486a5d4de35e6e2a
MISC metadata.xml 933 BLAKE2B 4382e8d75f379211e781a0309b483105cbdba740cbd473b29d6b892351d3a5d270487c759ba7a1f5bcad448222cb1c24ef8257cd089c54ce9df0523ff708888a SHA512 395c02c568874e3d22434431f5e72dd98a647455ec0587723cb447c4d5a2fb468256bb35aff2c74b8255203d21f4d844f5a4ad426037eeb907d67ffedeb6d74e
diff --git a/net-libs/ldns/ldns-1.8.3-r1.ebuild b/net-libs/ldns/ldns-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..b6b2d28818e4
--- /dev/null
+++ b/net-libs/ldns/ldns-1.8.3-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1 multilib-minimal
+
+DESCRIPTION="A library with the aim to simplify DNS programming in C"
+HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="https://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # missing test directory
+
+BDEPEND="
+ python? ( dev-lang/swig )
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+ >=dev-libs/openssl-1.1.1l-r1:0=[${MULTILIB_USEDEP},static-libs?]
+ examples? ( net-libs/libpcap )
+"
+RDEPEND="
+ ${DEPEND}
+ !<net-dns/ldns-utils-1.8.0-r2
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/ldns-config
+)
+
+PATCHES=(
+ "${FILESDIR}/ldns-1.8.1-pkgconfig.patch"
+ "${FILESDIR}/${P}-docs.patch"
+ "${FILESDIR}/${P}-configure-strict.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Drop after 1.8.3
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with python pyldns) \
+ $(multilib_native_use_with python pyldnsx) \
+ --with-ssl="${EPREFIX}"/usr \
+ $(multilib_native_with drill) \
+ $(multilib_native_use_with examples) \
+ --disable-rpath
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ dodoc -r doc/html
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc Changelog README*
+
+ find "${D}" -name '*.la' -delete || die
+ use python && python_optimize
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim
+}