summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin32815 -> 32819 bytes
-rw-r--r--net-libs/nghttp3/Manifest4
-rw-r--r--net-libs/nghttp3/nghttp3-0.8.0.ebuild39
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild4
4 files changed, 44 insertions, 3 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index b9f5c931709d..7b545f7ebec7 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 16733da6c8f7..4d45d30d5042 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,4 +1,6 @@
+DIST nghttp3-0.8.0.tar.xz 365072 BLAKE2B 132332f785f015a5e62e751ad6fe6d1dae49911837ef26cb24453245ca2cd5a80c92092db4b712f1fb515caa900ac190c2fa586fbf7314df9e60928595791679 SHA512 dab545aff7f85ee10c0f43985cb7f937e33a793c4bb0ca8e7878652f8d0b2500497cdd435256f401bf35a0c7af21aec08cd821beddff3e96b4810efb4c798591
DIST nghttp3-0_pre20190912.tar.gz 155172 BLAKE2B fabd472e429222502288b7a4030b4aa51f8a1b609590d63b51ab3f918b8cdb462b766a40911986b3f72f2f1b0debee1f0ebdf8802991bf4fc5d4a6d14297bdcc SHA512 89c7b40843bde9d2c2ab24211794b6ae0e1fa15413e92dcf2238b876552f29bb2f0db724d9a205c2a1c98f25a14ef570c9e53df52fb519230b6f78dcc04d2117
+EBUILD nghttp3-0.8.0.ebuild 824 BLAKE2B e2d6e52fedb5de2cdd870e92860f22071a69bec4cacef29fae479cdac922b7051a30ee866967962da69396e438e84f06b1b8774e49502446583c3c4e150b7268 SHA512 a49afbf4c1f26be6638963d345898101d6c9420ab0fc4b73829448a3b4b209d951550afc3fb438a8b49086e07d0c50950f472ae877a890adb9f34ec2cd65b284
EBUILD nghttp3-0_pre20190912.ebuild 922 BLAKE2B f88e6f9426efb68a0b257ce942b066834ffb9da6fc26ec88b58ae3c78d5c09fa2ebbd57f3604fa6b9b52834e15b15ba4f5edff11da8fa44c94491df3cd7bc2f6 SHA512 008393024ceb9fdef8369146478d09681ee492c4e6651425afaf3b68d98562ecfba51f18a3be1f3002cb17ff7b2b90d0a9ffee6ad1079ce5919e97cfb9475b17
-EBUILD nghttp3-9999.ebuild 824 BLAKE2B f9f144c836697c2dd60f74c0c459da87e6673c50480e86d6c0ce40fc163c3a5a4db5f3fdc23e967a5318b86eba898f2fdadd384d93fd81dce7ab960c5d539892 SHA512 0d23f3926ce0c78983f0641409a57763157521feed6066bc4bf682dc76070925bece88c5dc0e07a6a4109c7bb75bc3413b8c272b37f45909e07675469f91b30b
+EBUILD nghttp3-9999.ebuild 824 BLAKE2B e2d6e52fedb5de2cdd870e92860f22071a69bec4cacef29fae479cdac922b7051a30ee866967962da69396e438e84f06b1b8774e49502446583c3c4e150b7268 SHA512 a49afbf4c1f26be6638963d345898101d6c9420ab0fc4b73829448a3b4b209d951550afc3fb438a8b49086e07d0c50950f472ae877a890adb9f34ec2cd65b284
MISC metadata.xml 327 BLAKE2B 57c198cb15bb8a8982d7c93149b595e0fd03fb0b63cde2d49349dc3dcefa7873f310a4c6accf7089320c6a38376aef8bf6d98afe689d743c96636eebc53a2365 SHA512 580f5c33715cac0b138070349342d4d2e62c179e05aa1e66fc801001fa8dbb064d1291f8c38ff3b0e68cb392bc2f339c28afeab1d9a77d786497968fae2505a8
diff --git a/net-libs/nghttp3/nghttp3-0.8.0.ebuild b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
new file mode 100644
index 000000000000..3685e3ee33ca
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index c6ed60a92ab9..3685e3ee33ca 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake-multilib