summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin32474 -> 32468 bytes
-rw-r--r--net-libs/libupnp/Manifest2
-rw-r--r--net-libs/libupnp/libupnp-1.14.13.ebuild49
-rw-r--r--net-libs/nodejs/Manifest2
-rw-r--r--net-libs/nodejs/nodejs-18.7.0.ebuild225
-rw-r--r--net-libs/socket_wrapper/Manifest2
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild25
7 files changed, 305 insertions, 0 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index 3c01d9e9b4db..80f326b79174 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 8dc8bc82f8a2..641a74b0f165 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1,4 +1,6 @@
AUX libupnp-1.14.12-disable-network-tests.patch 416 BLAKE2B d1fea0b8e0abba960cd5296839977559bcc8081285f17de4a19e0d48557735bdee687f8d069976b3e97e5f0d5dde46063f1c8d83cd4df071bef439633d33b59c SHA512 e59e7695bad657b3e67efc3478f76ae2617732b22bbc7ea07b904260f0a73d7a57db83deedc58959f4335aba2c66c6bd0bf819051a7c4c8e412694883466d61b
DIST libupnp-1.14.12.tar.gz 788299 BLAKE2B 721c10f9fa4ffc60743b4ebf8be566ea595931cb1f2a2448d8e3cecfc787abfb855cb16256eaaa10ce6a901cd5e5b3d14672610841b2a718d5dd003ccfd3c2f0 SHA512 aab17aa12f15d110bfab20cbcbae5f54926b6ca7a30bce10b9287cd39919a06a5e9f1493405e1d561c0d58ba46926f87009df891e4e4f37097df1c3c67635ca9
+DIST libupnp-1.14.13.tar.gz 807484 BLAKE2B af3cd6c852297d7b131b2deefba8a72427e225c765017edb5f927b81bd1ce2b72d43caf2c46bd383b83536ba858d52dc8d051e272dacc8bd3c952e43443650a4 SHA512 ae6ae72a5e784a0f9508af94c4070627e791660fa37966e9825643fd0f88b171826bda9a2ec872d4961bf3454e5a9cd716127f0bdf6e63c789c4e22aab0b7e71
EBUILD libupnp-1.14.12-r1.ebuild 1118 BLAKE2B eae174b59a69315e1f08070aa27e585f685ae25f1896901dc9c56492573558e9df6a28993b856ee4ec2b66c37ce92a8353aea764747bd5ca0001ed3152ff81ae SHA512 743b8eab3e7225fb42d15d2207ff3e98c0d47241e1ebe5bb38300ebbf11781229c287a94b30e718d958db7bfd4c4088480912c024a2a49a7537675b936064d7e
+EBUILD libupnp-1.14.13.ebuild 1125 BLAKE2B 24f70e00702045579e1fe17af21039a5a034b054a9cf3c8d0f469147a71fd0d6216f059ed022369975c674f1320efb42220786b26adcff18148f1409c6f5d9ef SHA512 76e46607dcaa17e6e96038f25efc1209a8bd641d2e90b5aa2df0197d5a27bd6d99534f8d4f3107aa379368f0a009a15952b651600ffa0976e5c5ca5701ef9387
MISC metadata.xml 676 BLAKE2B a5aa120c6aef01b436d44e14c0d3d9014b4d3392c75322c5269bb56c6c143ad184d409def0adec6a02a4158b67c71e0cb009eb83d023a0346937337ce171dd6a SHA512 507660834175c3675b9ca6aeb4f5cdae1a017f54ba46e25d1a3235f05c897548b18ca294c328c167d35c8babb3aa71838880965bf34269559aac02a831addd17
diff --git a/net-libs/libupnp/libupnp-1.14.13.ebuild b/net-libs/libupnp/libupnp-1.14.13.ebuild
new file mode 100644
index 000000000000..a8b52238c73f
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc +ipv6 +reuseaddr samples +ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.12-disable-network-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable blocking-tcp blocking-tcp-connections)
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable reuseaddr)
+ $(use_enable samples)
+ $(use_enable ssl open_ssl)
+ $(use_enable static-libs static)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index 0e0d5bb440fa..48e1ac24fc99 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -8,8 +8,10 @@ AUX nodejs-18.3.0-paxmarking.patch 3303 BLAKE2B 627ef3dac873d7967181cbe44b356608
DIST node-v14.20.0.tar.xz 34487684 BLAKE2B a3b8af94d2bb0e52f36ead91a5cd96a4a35a67f07b87e43da5ff598d693fd8b3b47c05dbb6c6b738aefa55b056eccedbcf782225a2abf49110b3371a544952bd SHA512 400eb247c1d37ca64f4d643ab1852d2e1415ee190cf726b1e9b058386a1ebd6d7a9f40092afff228ec7980f37a78978252c1ef115aee47ec5b90c065f136b10f
DIST node-v16.16.0.tar.xz 35039712 BLAKE2B e4cf7debda3d32b515d60d11ac7ebd788fdab0ebc782a096571cd4b502dddfb9c63c9a3625198c6c545f95092ffcb247e94ee96e33d8a79a7c5e24c56039c229 SHA512 828bfee4f3789b02fec512a7d9785bf02650401c61b2d3ff80d8a3876420927fb9c8d0c2d66e45e1e8370c47cb81140d434747588322c4fedca7fd9e42b84ac3
DIST node-v18.6.0.tar.xz 37189620 BLAKE2B 15a8a874f39db7de576d3ba81fddcb8072cb170ebb12308d2ade2efb9c8200c561671f453371a16db82d4c0f02522a28f6ae01216d11be40df94b53b184828b3 SHA512 d682e25a71ffbef90e2cb3c55e22dbd548952c4de24d48c47206afd270fd17c7bda95b3241840bf6a470f28d2389f3c6fddbb812ad17cf1d36262ff25fcda859
+DIST node-v18.7.0.tar.xz 36945328 BLAKE2B 8ec945347ba396f7c65f544325690abdece4aa82ce1dae63e56662c78f445845f3f858a803ee2b130444f44cd38f4e1d8f5df0240d5a0c5124a38cbab42daafc SHA512 3da56b25f304b4e205c27a59f2e442e7216e494465e4cce9f51ffd3f7c7da3ab3519c4b7d1eb41a754b86ecfa1d138d270578aa3908b4fd42cc5dbfd389a6798
EBUILD nodejs-14.20.0.ebuild 6747 BLAKE2B 49b3fc16ce3a525cacb79d31d5ca7b9293fef86ac7190513dac98cd501829ecc7cba46e119ae822e381ed8a33cd558af7841d79d7b07335408156f9a5e9fdcc6 SHA512 f0752f3f9df46842f9574364ce0088d1a06eece13fca94965547c4da2129cd8f4d99480619ee1dfdb3fe18b6314505f81918f7a51787cdf848f688152c41e0c6
EBUILD nodejs-16.16.0.ebuild 6361 BLAKE2B 24bfc86983bd48e388dd0114cddc3c3d62e9b45de3564eaec0a5e0350546df0127500224d6ad9a6741dbdf54a1781593adf0b0256ab94809c9b7ef0d0a501705 SHA512 811a59e98a48a26cdb691ca42225cade47d93105de9f4b2253a9f627b27ddfdd569e6734ddb05ac2e24cef6844c4649257486aedd96c9d3ccf16389876d439f9
EBUILD nodejs-18.6.0.ebuild 6361 BLAKE2B 35b15b80127645ad32194c32964b60d91b734efe6747e518d467794245c84d4a760f097c782d2f20456e4e5e118de26632c1680d0a46d6fa1a1ac0d9d23bfaf2 SHA512 9776b6ced2df5251f10141b979c81711abb0a84fd7215716a22004279f3e9646d272ddf1c957e8448a99d5dfc5862453292f386c8d84aea96df98cd96d7e3dd0
+EBUILD nodejs-18.7.0.ebuild 6366 BLAKE2B 28182130632e2ef7c96ed8d82e951a8d384deba2bd71378deb312dca42ea672dac5f9d7c2bb2f04b37c60d14e81e69f9583cd6dd8483c5992af94ef1d3844dcd SHA512 c6c5984ff9b1172937bce7c4a3413866c6060df9e8d73ac5ae41fbbbe0d8304b11afc182281dc760f2e500b74d4f4f2ba67256cfb459301e2e190d05c0294973
EBUILD nodejs-99999999.ebuild 6135 BLAKE2B dc0d8749313aeb1445ac553917527fd653927869cc0cbae3ac9cab5886d55796faff814ae2699beaf2f2b5b047a7193bd812932b1d2d7bd0cfd60f406a7195ae SHA512 3d0d4c9694154291c07c374de2acd61242f5a184aa550b3bb5ab1c6ce86d9feeb33187487c60a59ee91ec99bcaa5713efda531b2b009f31c89e2fe6fa432eba2
MISC metadata.xml 898 BLAKE2B a67e85ea95c272b8d18746254894b058433267a74b5bad66bac7d78c7db4cec297e06bc87fad3ee836fc91749aaee2c11c88b48b6ba033c36fa79132552faa81 SHA512 d498b288058e7282c5e9a28d4ba192a2ac5ef796eb1edf644aea41cab2d0eb6036426b188dd9af7eeb2eaf04b84011460cb3c3695ca8dde5667add21d9963c97
diff --git a/net-libs/nodejs/nodejs-18.7.0.ebuild b/net-libs/nodejs/nodejs-18.7.0.ebuild
new file mode 100644
index 000000000000..a697753f345e
--- /dev/null
+++ b/net-libs/nodejs/nodejs-18.7.0.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CONFIG_CHECK="~ADVISE_SYSCALLS"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 flag-o-matic linux-info pax-utils python-any-r1 toolchain-funcs xdg-utils
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nodejs/node"
+ SLOT="0"
+else
+ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+ SLOT="0/$(ver_cut 1)"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
+ S="${WORKDIR}/node-v${PV}"
+fi
+
+IUSE="cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl systemtap test"
+REQUIRED_USE="inspector? ( icu ssl )
+ npm? ( ssl )
+ system-icu? ( icu )
+ system-ssl? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-arch/brotli-1.0.9:=
+ >=dev-libs/libuv-1.40.0:=
+ >=net-dns/c-ares-1.17.2:=
+ >=net-libs/nghttp2-1.41.0:=
+ sys-libs/zlib
+ system-icu? ( >=dev-libs/icu-67:= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )"
+BDEPEND="${PYTHON_DEPS}
+ sys-apps/coreutils
+ virtual/pkgconfig
+ systemtap? ( dev-util/systemtap )
+ test? ( net-misc/curl )
+ pax-kernel? ( sys-apps/elfix )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-12.22.5-shared_c-ares_nameser_h.patch
+ "${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
+)
+
+pkg_pretend() {
+ (use x86 && ! use cpu_flags_x86_sse2) && \
+ die "Your CPU doesn't support the required SSE2 instruction."
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ tc-export AR CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ sed -i -e "/'-O3'/d" common.gypi node.gypi || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ # We need to disable mprotect on two files when it builds Bug 694100.
+ use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-18.3.0-paxmarking.patch )
+
+ # All this test does is check if the npm CLI produces warnings of any sort,
+ # failing if it does. Overkill, much? Especially given one possible warning
+ # is that there is a newer version of npm available upstream (yes, it does
+ # use the network if available), thus making it a real possibility for this
+ # test to begin failing one day even though it was fine before.
+ rm -f test/parallel/test-release-npm.js
+
+ default
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ # LTO compiler flags are handled by configure.py itself
+ filter-flags '-flto*'
+
+ local myconf=(
+ --shared-brotli
+ --shared-cares
+ --shared-libuv
+ --shared-nghttp2
+ --shared-zlib
+ )
+ use debug && myconf+=( --debug )
+ use lto && myconf+=( --enable-lto )
+ if use system-icu; then
+ myconf+=( --with-intl=system-icu )
+ elif use icu; then
+ myconf+=( --with-intl=full-icu )
+ else
+ myconf+=( --with-intl=none )
+ fi
+ use inspector || myconf+=( --without-inspector )
+ use npm || myconf+=( --without-npm )
+ use snapshot || myconf+=( --without-node-snapshot )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
+
+ local myarch=""
+ case ${ABI} in
+ amd64) myarch="x64";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ lp64*) myarch="riscv64";;
+ ppc64) myarch="ppc64";;
+ x32) myarch="x32";;
+ x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${EPYTHON}" configure.py \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ $(use_with systemtap dtrace) \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ default
+
+ pax-mark -m "${ED}"/usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ docinto html
+ dodoc -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ keepdir /etc/npm
+
+ # Install bash completion for `npm`
+ local tmp_npm_completion_file="$(TMPDIR="${T}" mktemp -t npm.XXXXXXXXXX)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm -f "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile}
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man}
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+
+ mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
+}
+
+src_test() {
+ if has usersandbox ${FEATURES}; then
+ rm -f "${S}"/test/parallel/test-fs-mkdir.js
+ ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
+ "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
+ fi
+
+ out/${BUILDTYPE}/cctest || die
+ "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
+}
diff --git a/net-libs/socket_wrapper/Manifest b/net-libs/socket_wrapper/Manifest
index 67af2793308b..fb6a4b369e94 100644
--- a/net-libs/socket_wrapper/Manifest
+++ b/net-libs/socket_wrapper/Manifest
@@ -1,3 +1,5 @@
DIST socket_wrapper-1.3.2.tar.gz 86255 BLAKE2B 33f526a8871cfb1a889a84660ea8e82b6e591646924e16d2c452bb001e0eb4c1457b8151208bbec55c13c40fd124c160fc85d0df227519f62a2683e4ea1acb85 SHA512 f4d3a7026f1777a4c3b5481a0f6e6057b6372e9b64f44523ec1ebf0a34159d7154493dce6ee3c95fbea15607c6ada1382f2475d5d553133a061c80719c135b9d
+DIST socket_wrapper-1.3.4.tar.gz 81997 BLAKE2B 5d290ef59c16fbdde362749196cc91c3f050518f82cb14fbafa3e00d5fb51a6b085b94b08413ca601731440d8eadb5dfbe8d011567fd67b1240b0cc380504813 SHA512 6e6a940e26d0f4dc4f1c0f84643d5a124bb2cccd1713481e9c42ea7986884928d736b1ef8da8a2aef3d3803938b6e1ebd30bdbe9784fda95a9a59cdbd1d19f61
EBUILD socket_wrapper-1.3.2.ebuild 632 BLAKE2B 176e16ce60bae63d746d7fb456c2af5ec16df8f32be0c7104e13c4f6447ab371a596fbff4259786bce0898973d5a42cd78aff6d15471c093520d8d15cce64545 SHA512 762b3ed57bf532e9a58aae01e574e0cf30bbfed51aba5ab9dd20b7a0e159759dde8fb50abdcad894b394713e93cdc2d79be87ca9b95b451ee0080403159cb905
+EBUILD socket_wrapper-1.3.4.ebuild 619 BLAKE2B c1ecfd3e196cb868e6ba0ecb973ff68fa49d59ca18e12ae2a1b1f38e4f238af011d9fa5d9909ebe8999f29e4f65974555c65c6225495dd913636348c31bfeb4e SHA512 c406ed7c9f6d670e9dd24d799cd9ba5c47504329a9e30de664d8bcee3361e9d603a4140253fbb063876d8e06cef2e8dcd7c814e6fb9122411c40128148dc1e8b
MISC metadata.xml 250 BLAKE2B e398673dd1a3522ccddb89a82a53fc2578d8e0777ec46f889d01d618609a22958d91699beef513c7912799e0e8ff985200f7c67bba941235da25c24cd4b48f09 SHA512 16834c3cbecd0dd5a9c8c311d2b8ebc63d8cd72c5891498f4f0048988993c104aadd4e24e632bf54071c11f810716432e89e4afab029555875f9f52794daa6e9
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
new file mode 100644
index 000000000000..52c36e4a8cc9
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}