summaryrefslogtreecommitdiff
path: root/net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild
index 0af88789a7fa..460653b5eb96 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.40.5.ebuild
@@ -120,6 +120,10 @@ S="${WORKDIR}/${MY_P}"
CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+# We cannot use PATCHES because src_prepare() calls cmake_src_prepare and
+# gnome2_src_prepare, and both apply ${PATCHES[@]}
+PATCHES=()
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]] ; then
if is-flagq "-g*" && ! is-flagq "-g*0" ; then
@@ -144,6 +148,8 @@ pkg_setup() {
src_prepare() {
cmake_src_prepare
gnome2_src_prepare
+
+ eapply "${FILESDIR}/${PV}-Fix-build-failure-when-gstreamer-support-is-disabled.patch"
}
src_configure() {