summaryrefslogtreecommitdiff
path: root/net-libs/webkit-gtk/files/2.20.3-jsc-build-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/files/2.20.3-jsc-build-fixes.patch')
-rw-r--r--net-libs/webkit-gtk/files/2.20.3-jsc-build-fixes.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/2.20.3-jsc-build-fixes.patch b/net-libs/webkit-gtk/files/2.20.3-jsc-build-fixes.patch
new file mode 100644
index 000000000000..32ff3a52844f
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.20.3-jsc-build-fixes.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/662002
+https://bugs.webkit.org/show_bug.cgi?id=183788
+https://trac.webkit.org/changeset/229282/webkit
+
+Index: /trunk/Source/JavaScriptCore/CMakeLists.txt
+===================================================================
+--- a/Source/JavaScriptCore/CMakeLists.txt (revision 229281)
++++ b/Source/JavaScriptCore/CMakeLists.txt (revision 229282)
+@@ -248,4 +248,5 @@
+ )
+ target_link_libraries(LLIntOffsetsExtractor WTF)
++add_dependencies(LLIntOffsetsExtractor JavaScriptCoreForwardingHeaders)
+
+ # The build system will execute asm.rb every time LLIntOffsetsExtractor's mtime is newer than