summaryrefslogtreecommitdiff
path: root/net-libs/wandio/wandio-4.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/wandio/wandio-4.2.1.ebuild')
-rw-r--r--net-libs/wandio/wandio-4.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/wandio/wandio-4.2.1.ebuild b/net-libs/wandio/wandio-4.2.1.ebuild
new file mode 100644
index 000000000000..b2404e7e7a1c
--- /dev/null
+++ b/net-libs/wandio/wandio-4.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="C library for simple and efficient file IO"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://github.com/wanduow/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs test zlib"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-arch/lzop )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}
+
+src_test() {
+ pushd test || die
+ sh do-basic-tests.sh
+}