summaryrefslogtreecommitdiff
path: root/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild')
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
index 12ca100f7091..021e7a634ee6 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-any-r1 cmake virtualx
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
@@ -17,6 +17,8 @@ IUSE="debug farstream test"
REQUIRED_USE="test? ( farstream )"
+RESTRICT="!test? ( test )"
+
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -43,7 +45,6 @@ BDEPEND="${PYTHON_DEPS}
')
)
"
-RESTRICT="!test? ( test )"
python_check_deps() {
use test || return 0