summaryrefslogtreecommitdiff
path: root/net-libs/srt/srt-1.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/srt/srt-1.5.3.ebuild')
-rw-r--r--net-libs/srt/srt-1.5.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-libs/srt/srt-1.5.3.ebuild b/net-libs/srt/srt-1.5.3.ebuild
index b4dc27c9ac23..de20957ff470 100644
--- a/net-libs/srt/srt-1.5.3.ebuild
+++ b/net-libs/srt/srt-1.5.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2018-2023 Gentoo Authors
+# Copyright 2018-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="Secure Reliable Transport (SRT) library and tools"
HOMEPAGE="https://github.com/Haivision/srt"
@@ -35,6 +35,10 @@ BDEPEND="virtual/pkgconfig
test? ( >=dev-cpp/gtest-1.10[${MULTILIB_USEDEP}] )"
src_configure() {
+ # ODR violations
+ # https://github.com/Haivision/srt/issues/2145 (bug #861584)
+ filter-lto
+
local mycmakeargs=(
-DUSE_CXX_STD=c++14 # Required for gtest
-DENABLE_STATIC=OFF