summaryrefslogtreecommitdiff
path: root/net-libs/rtrlib/rtrlib-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rtrlib/rtrlib-0.8.0.ebuild')
-rw-r--r--net-libs/rtrlib/rtrlib-0.8.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-libs/rtrlib/rtrlib-0.8.0.ebuild b/net-libs/rtrlib/rtrlib-0.8.0.ebuild
index d903cb14d3bb..50d2d94eb403 100644
--- a/net-libs/rtrlib/rtrlib-0.8.0.ebuild
+++ b/net-libs/rtrlib/rtrlib-0.8.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="An open-source C implementation of the RPKI/Router Protocol client"
HOMEPAGE="https://rtrlib.realmv6.org/"
@@ -32,6 +32,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861581
+ # https://github.com/rtrlib/rtrlib/issues/287
+ #
+ # Do not trust LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DRTRLIB_TRANSPORT_SSH=$(usex ssh)
)