summaryrefslogtreecommitdiff
path: root/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild43
1 files changed, 22 insertions, 21 deletions
diff --git a/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild b/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
index 688a4490a702..a8bd6e94ae7d 100644
--- a/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
+++ b/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,34 +27,35 @@ DEPEND="${RDEPEND}
test? ( dev-qt/qttest:5 )
"
-src_prepare(){
+src_prepare() {
+ default
+
if ! use doc; then
- sed -i \
- -e '/SUBDIRS/s/doc//' \
+ sed -e '/SUBDIRS/s/doc//' \
-e '/INSTALLS/d' \
- qxmpp.pro || die "sed for removing docs failed"
+ -i qxmpp.pro || die "failed to remove docs"
fi
if ! use test; then
- sed -i -e '/SUBDIRS/s/tests//' \
- qxmpp.pro || die "sed for removing tests failed"
+ sed -e '/SUBDIRS/s/tests//' \
+ -i qxmpp.pro || die "failed to remove tests"
+ else
+ # requires network connection, bug #623708
+ sed -e "/qxmppiceconnection/d" \
+ -i tests/tests.pro || die "failed to drop single test"
fi
# There is no point in building examples. Also, they require dev-qt/qtgui
- sed -i -e '/SUBDIRS/s/examples//' \
- qxmpp.pro || die "sed for removing examples failed"
- default_src_prepare
+ sed -e '/SUBDIRS/s/examples//' \
+ -i qxmpp.pro || die "sed for removing examples failed"
}
-src_configure(){
- local conf_speex
- local conf_theora
- local conf_vpx
-
- use opus && conf_opus="QXMPP_USE_OPUS=1"
- use speex && conf_speex="QXMPP_USE_SPEEX=1"
- use theora && conf_theora="QXMPP_USE_THEORA=1"
- use vpx && conf_vpx="QXMPP_USE_VPX=1"
-
- eqmake5 "${S}"/qxmpp.pro "PREFIX=${EPREFIX}/usr" "LIBDIR=$(get_libdir)" "${conf_opus}" "${conf_speex}" "${conf_theora}" "${conf_vpx}"
+src_configure() {
+ eqmake5 "${S}"/qxmpp.pro \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="$(get_libdir)" \
+ QXMPP_USE_OPUS=$(usex opus 1 0) \
+ QXMPP_USE_SPEEX=$(usex speex 1 0) \
+ QXMPP_USE_THEORA=$(usex theora 1 0) \
+ QXMPP_USE_VPX=$(usex vpx 1 0)
}
src_install() {