summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-4.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-4.9.1.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-4.9.1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-4.9.1.ebuild b/net-libs/nodejs/nodejs-4.9.1.ebuild
index d3f61ffab162..4c5b0406ddad 100644
--- a/net-libs/nodejs/nodejs-4.9.1.ebuild
+++ b/net-libs/nodejs/nodejs-4.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit flag-o-matic pax-utils python-single-r1 toolchain-funcs
+inherit flag-o-matic pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -28,7 +28,6 @@ DEPEND="${RDEPEND}
test? ( net-misc/curl )"
S="${WORKDIR}/node-v${PV}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
pkg_pretend() {
(use x86 && ! use cpu_flags_x86_sse2) && \