summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-16.0.0-r1.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-16.0.0-r1.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
index e9e14a673451..95528f2021f9 100644
--- a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
+++ b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
@@ -22,7 +22,7 @@ REQUIRED_USE="inspector? ( icu ssl )
system-icu? ( icu )
system-ssl? ( ssl )"
-# FIXME: test-fs-mkdir fails with "no such file or directory". Investigate.
+# As of 16.0.0, tests fail because "npm is not ready for this release"
RESTRICT="test"
RDEPEND=">=app-arch/brotli-1.0.9
@@ -41,6 +41,7 @@ BDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
PATCHES=(
+ "${FILESDIR}"/${PN}-12.22.1-uvwasi_shared_libuv.patch
"${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
"${FILESDIR}"/${PN}-16.0.0-v8_lto.patch
)
@@ -53,7 +54,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}
@@ -209,6 +218,12 @@ src_install() {
}
src_test() {
+ # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
+ if has usersandbox ${FEATURES}; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
}