summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-10.19.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-10.19.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-10.19.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-10.19.0.ebuild b/net-libs/nodejs/nodejs-10.19.0.ebuild
index 31d605f6adb2..1aedca2b28c8 100644
--- a/net-libs/nodejs/nodejs-10.19.0.ebuild
+++ b/net-libs/nodejs/nodejs-10.19.0.ebuild
@@ -13,10 +13,11 @@ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl +system-ssl systemtap test"
REQUIRED_USE="
inspector? ( icu ssl )
npm? ( ssl )
+ system-ssl? ( ssl )
"
RDEPEND="
@@ -26,7 +27,7 @@ RDEPEND="
>=net-libs/nghttp2-1.39.2
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
- ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
"
DEPEND="
${RDEPEND}
@@ -99,7 +100,11 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
- use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl )
+ else
+ myconf+=( --without-ssl )
+ fi
local myarch=""
case ${ABI} in