summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-0.12.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-0.12.18.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-0.12.18.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-0.12.18.ebuild b/net-libs/nodejs/nodejs-0.12.18.ebuild
index f45d645a9c59..40890e986795 100644
--- a/net-libs/nodejs/nodejs-0.12.18.ebuild
+++ b/net-libs/nodejs/nodejs-0.12.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ RESTRICT="test"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit pax-utils python-single-r1 toolchain-funcs
+inherit pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="Evented IO for V8 Javascript"
HOMEPAGE="http://nodejs.org/"
@@ -28,7 +28,6 @@ RDEPEND="icu? ( dev-libs/icu )
DEPEND="${RDEPEND}"
S="${WORKDIR}/node-v${PV}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
tc-export CC CXX PKG_CONFIG