summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest2
-rw-r--r--net-libs/nghttp3/nghttp3-1.3.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index abd92209b76b..df50d2683295 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,4 +1,6 @@
DIST nghttp3-1.2.0.tar.xz 387592 BLAKE2B b3ad897fda5d616a93f063bafde760eda6f597c90de6c81793abef3ff30de05bb2a06388fa868f95c0871a6592331d17a2d344c63817179ad21c6390bc0e499b SHA512 51ade6b17215eb15c92b18ad7a94b70e0a442d5968aee31ec734e5826d09ca34197e64407a1ac3f7bfb4ed1a0b3c3b58afc4a152542bacdcc4c71140931a7652
+DIST nghttp3-1.3.0.tar.xz 390176 BLAKE2B 8ff17da3e53efb27b13e9ab17dba4ca27cc8fd948b160a36a0b0496f61a49c2729f1281f9a29cb8fecd4dd2c274696885a3c5e001be3dcfc30f5f1c9b6339467 SHA512 a862e7a3c3f6722b07d5437976850b2998032d1f7b9da7a49e6863d59c611ff7204c9923e8e570301a9bfbd91931a30f8f85e96cfb35481783adfc2f955a8b8c
EBUILD nghttp3-1.2.0-r2.ebuild 742 BLAKE2B e279425fed0370a7b99265a40b05f88ee0fb26a92d6b2fcb34be2b89d501d53db508a58cffdd12e40450cc74d73a27540504119c7225d583f7ea335822eab0c8 SHA512 23a87ea01d7396498e8a5ddd9b7106451fcbd693b3670e1db1d99d9ff69d67711dbe105450ada8e6caf32f622ae392a31c74fe7807f379c89545f456f56f7dc1
+EBUILD nghttp3-1.3.0.ebuild 742 BLAKE2B e279425fed0370a7b99265a40b05f88ee0fb26a92d6b2fcb34be2b89d501d53db508a58cffdd12e40450cc74d73a27540504119c7225d583f7ea335822eab0c8 SHA512 23a87ea01d7396498e8a5ddd9b7106451fcbd693b3670e1db1d99d9ff69d67711dbe105450ada8e6caf32f622ae392a31c74fe7807f379c89545f456f56f7dc1
EBUILD nghttp3-9999.ebuild 742 BLAKE2B e279425fed0370a7b99265a40b05f88ee0fb26a92d6b2fcb34be2b89d501d53db508a58cffdd12e40450cc74d73a27540504119c7225d583f7ea335822eab0c8 SHA512 23a87ea01d7396498e8a5ddd9b7106451fcbd693b3670e1db1d99d9ff69d67711dbe105450ada8e6caf32f622ae392a31c74fe7807f379c89545f456f56f7dc1
MISC metadata.xml 327 BLAKE2B 57c198cb15bb8a8982d7c93149b595e0fd03fb0b63cde2d49349dc3dcefa7873f310a4c6accf7089320c6a38376aef8bf6d98afe689d743c96636eebc53a2365 SHA512 580f5c33715cac0b138070349342d4d2e62c179e05aa1e66fc801001fa8dbb064d1291f8c38ff3b0e68cb392bc2f339c28afeab1d9a77d786497968fae2505a8
diff --git a/net-libs/nghttp3/nghttp3-1.3.0.ebuild b/net-libs/nghttp3/nghttp3-1.3.0.ebuild
new file mode 100644
index 000000000000..6715be902969
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}