summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3/nghttp3-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3/nghttp3-9999.ebuild')
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 719966f4eab6..6715be902969 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~hppa"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
fi
DESCRIPTION="HTTP/3 library written in C"
@@ -18,19 +18,16 @@ HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
LICENSE="MIT"
SLOT="0/0"
-IUSE="static-libs test"
+IUSE="static-libs"
BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
RDEPEND=""
-RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=(
-DENABLE_LIB_ONLY=ON
-DENABLE_STATIC_LIB=$(usex static-libs)
-DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
cmake_src_configure
}