summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3/nghttp3-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3/nghttp3-0.8.0.ebuild')
-rw-r--r--net-libs/nghttp3/nghttp3-0.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/nghttp3/nghttp3-0.8.0.ebuild b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
new file mode 100644
index 000000000000..3685e3ee33ca
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}