summaryrefslogtreecommitdiff
path: root/net-libs/libtelnet/libtelnet-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtelnet/libtelnet-9999.ebuild')
-rw-r--r--net-libs/libtelnet/libtelnet-9999.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/net-libs/libtelnet/libtelnet-9999.ebuild b/net-libs/libtelnet/libtelnet-9999.ebuild
index 9edf0466d6a4..bf00b8db2d1e 100644
--- a/net-libs/libtelnet/libtelnet-9999.ebuild
+++ b/net-libs/libtelnet/libtelnet-9999.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-inherit cmake
+EAPI=8
if [[ ${PV} == *9999 ]]; then
- inherit git-r3
EGIT_REPO_URI="https://github.com/seanmiddleditch/libtelnet.git"
+ inherit git-r3 cmake
else
+ inherit autotools
SRC_URI="https://github.com/seanmiddleditch/libtelnet/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -19,10 +18,19 @@ HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
LICENSE="public-domain"
SLOT="0"
-# needed unconditionally for man pages
-BDEPEND="app-doc/doxygen"
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-doc/doxygen
+ virtual/pkgconfig
+"
-PATCHES=(
- # https://bugs.gentoo.org/737886
- "${FILESDIR}/${P}-doc.patch"
-)
+src_prepare() {
+ default
+ if [[ ${PV} = *9999 ]]; then
+ eapply "${FILESDIR}"/${P}-doc.patch
+ cmake_src_prepare
+ else
+ eautoreconf
+ fi
+}