summaryrefslogtreecommitdiff
path: root/net-libs/libssh
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/Manifest2
-rw-r--r--net-libs/libssh/libssh-0.9.5.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index 636db5749d21..2280c5882194 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,5 +1,7 @@
AUX libssh-0.8.0-tests.patch 503 BLAKE2B 22c3527e4b06ab9a00936e84c66ed14c7163a285aa5c88cfec5543e7c7aada8ffb716e20f3d3a0fef9425e244629f0d1c35250bdb9ce454b6cb247a3537cd411 SHA512 43145c2c202510ebe5cf64b47a6963b9335a844997f986938eacb0171a129863cdbd2676b8016941c85ec8c820d0543b8ab20f6aca5af86b3506e78aa29cf7e8
DIST libssh-0.9.4.tar.xz 500776 BLAKE2B 56b21faac5d24f38c4fe695b31ec879ebab74f7cbfb8b8d336dee37766b7b0802ccac9b02726515ee29d44e18e832cfa322085d5669de1df94e5a428cf9add0f SHA512 38705c19c293ea5e6d286d22eb17021dbe58d88c1e647b699933aa0db9ca1174d43d1ff76c1a1b17bf2cc1a8297ec02f1a67dd9e969676dd69cf6fbdae9bc8d4
+DIST libssh-0.9.5.tar.xz 502876 BLAKE2B 8ea07bf25218563cbbdab31683e679f71298e2c7c9bb2430195e84892838cd55b9025ed292de65c4942ecec7d4037d5b92a414232fca6c8e41821776f4cf815c SHA512 64e692a0bfa7f73585ea7b7b8b1d4c9a7f9be59565bfd4de32ca8cd9db121f87e7ad51f5c80269fbd99545af34dcf1894374ed8a6d6c1ac5f8601c026572ac18
EBUILD libssh-0.9.4.ebuild 3190 BLAKE2B 1e427a29c63f83cc1e12d4042c612dba16601ac1e8b9608999ca155c3bd95ce26ec9a9d73736704659548b5b6f8a830a413968753d87c2bcc2853b16b519e117 SHA512 255b96b1a34adf672c7bc1ae27572b3aacb918b607ad7eedbb631c72bc3b2a16dcdd1f4b0761f9e49e65d112224dc4ca768cd4f03e31d585632d0820af29ae24
+EBUILD libssh-0.9.5.ebuild 3198 BLAKE2B 7c0c30d1201aa21acc97be9d08529232c9e9b075dbe861e37b987307f7cfacb7540b59f99682fe1582b6dde44fea98740c4547cdaeca81c1861ad33a9060c48c SHA512 b2ed19610d62456c42d38544aa58a7ffc48b60ebc6424b6006e1eb3b668d3ed98bf05228c23cea8806bdc92a9bac0f4821fca2a7eb7f182b9489d840a45bc81f
EBUILD libssh-9999.ebuild 3198 BLAKE2B 7c0c30d1201aa21acc97be9d08529232c9e9b075dbe861e37b987307f7cfacb7540b59f99682fe1582b6dde44fea98740c4547cdaeca81c1861ad33a9060c48c SHA512 b2ed19610d62456c42d38544aa58a7ffc48b60ebc6424b6006e1eb3b668d3ed98bf05228c23cea8806bdc92a9bac0f4821fca2a7eb7f182b9489d840a45bc81f
MISC metadata.xml 628 BLAKE2B d00b92769be46eda265251a9ed4f6193901325d1acbe7431322a8e8703bab28bee8cf37356e258fea14477afe1de039328e71d85f05d997ebbecbe632cd5f6c2 SHA512 a583a03a4c8daeaca89d51aa100b257d82b3a5483c66a81d8c5d5d9a93434fef2bc8f8cb8bd417e4593426a463cdf6d13272305e2296cc5bef37a02a9ef6a474
diff --git a/net-libs/libssh/libssh-0.9.5.ebuild b/net-libs/libssh/libssh-0.9.5.ebuild
new file mode 100644
index 000000000000..8496b7dfd382
--- /dev/null
+++ b/net-libs/libssh/libssh-0.9.5.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
+"
+
+DOCS=( AUTHORS README ChangeLog )
+
+PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
+
+RESTRICT+=" !test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
+
+ # keyfile torture test is currently broken
+ sed -e "/torture_keyfiles/d" \
+ -i tests/unittests/CMakeLists.txt || die
+
+ # disable tests that take too long (bug #677006)
+ if use sparc; then
+ sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
+ -i tests/unittests/CMakeLists.txt || die
+ fi
+
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DWITH_NACL=OFF
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
+ -DWITH_DEBUG_CALLTRACE="$(usex debug)"
+ -DWITH_DEBUG_CRYPTO="$(usex debug)"
+ -DWITH_GCRYPT="$(usex gcrypt)"
+ -DWITH_GSSAPI="$(usex gssapi)"
+ -DWITH_MBEDTLS="$(usex mbedtls)"
+ -DWITH_PCAP="$(usex pcap)"
+ -DWITH_SERVER="$(usex server)"
+ -DWITH_SFTP="$(usex sftp)"
+ -DBUILD_STATIC_LIB="$(usex static-libs)"
+ -DUNIT_TESTING="$(usex test)"
+ -DWITH_ZLIB="$(usex zlib)"
+ )
+
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
+}
+
+multilib_src_install() {
+ cmake_src_install
+ multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ use static-libs && dolib.a src/libssh.a
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}