summaryrefslogtreecommitdiff
path: root/net-libs/libssh2/libssh2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libssh2/libssh2-9999.ebuild')
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
index 7aa0edfae11e..290d28ce2558 100644
--- a/net-libs/libssh2/libssh2-9999.ebuild
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -12,9 +12,9 @@ EGIT_REPO_URI="https://github.com/libssh2/libssh2"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="gcrypt mbedtls zlib"
+IUSE="gcrypt mbedtls test zlib"
REQUIRED_USE="?? ( gcrypt mbedtls )"
-RESTRICT="test"
+RESTRICT="!test? ( test )"
RDEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
@@ -29,7 +29,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
+ "${FILESDIR}"/${PN}-1.11.0-mansyntax_sh.patch
)
multilib_src_configure() {
@@ -42,8 +42,11 @@ multilib_src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING=$(usex test)
-DCRYPTO_BACKEND=${crypto_backend}
-DENABLE_ZLIB_COMPRESSION=$(usex zlib)
+ -DRUN_SSHD_TESTS=OFF
+ -DRUN_DOCKER_TESTS=OFF
)
cmake_src_configure
}