summaryrefslogtreecommitdiff
path: root/net-libs/libkvkontakte
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libkvkontakte')
-rw-r--r--net-libs/libkvkontakte/Manifest3
-rw-r--r--net-libs/libkvkontakte/files/libkvkontakte-5.0.0-fix-warnings.patch386
-rw-r--r--net-libs/libkvkontakte/libkvkontakte-5.0.0-r1.ebuild (renamed from net-libs/libkvkontakte/libkvkontakte-5.0.0.ebuild)6
3 files changed, 392 insertions, 3 deletions
diff --git a/net-libs/libkvkontakte/Manifest b/net-libs/libkvkontakte/Manifest
index 3510437e7741..e41f30018164 100644
--- a/net-libs/libkvkontakte/Manifest
+++ b/net-libs/libkvkontakte/Manifest
@@ -1,3 +1,4 @@
+AUX libkvkontakte-5.0.0-fix-warnings.patch 11751 BLAKE2B 5d8f45c2c8b6205e0475067e8dce671b1329f5775a799792792a53b9636f7cd707fafbff2af2cc197b45a65b899c9e23112acd93ac0d7657e0c0e18130d4eb31 SHA512 f1596051b35f999589f5c48347ba5f303a9af97fa8affc70189e27464579f50e583fcb3d7ea6286f9cf2a30306b56f05abc2146825620f6938b409bbe87af61a
DIST libkvkontakte-5.0.0.tar.xz 59116 BLAKE2B 18b4b3c0eb7e408a94c1d2d3613b4c2ef3c485490490aaee42a35175c81453961773031030ba3cfdf9c29fec7f73f7670d93d0c9ac1f748b33dc66d497434c19 SHA512 bc7fa3d2d8a815c3a8b2265bf45500c10ac31383883a6a19802c5d01be5c16c1e72a8fe0c2c7cc086c9a7403ce001df0629e546caa872a2ae599e3a2650ef1af
-EBUILD libkvkontakte-5.0.0.ebuild 732 BLAKE2B e121c1d583e55199202d0714b8317d9dbc4f370406f2192060abfe9192ff753446a58c9f56ae13b45b294660de372b7545c8f91e000530a1f4d0385cc9dd1183 SHA512 6a6fdd2755cbdea3a5de58770d0866ae9d733c3f0dc2efda36b860b8835450d4412085a49989c92d7da7efa79cde956c5e3b37003979f7926e9ce8351ee12e69
+EBUILD libkvkontakte-5.0.0-r1.ebuild 800 BLAKE2B 9d09056a301aee1105291a7898528795cc2a3586206155bc96c8b6864486c0939c27fdab4b6230c274835a6b13f3b63221037f3a8d69ffe1c9b503598f0d1e56 SHA512 477b0889f7adf6b3ac681d78b099ea782e31b9f44b3aa819c74510143c1bc91c09c8a874994ebcf67500e04988ac48a32e621fa68ee91af67d5f112807638058
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/net-libs/libkvkontakte/files/libkvkontakte-5.0.0-fix-warnings.patch b/net-libs/libkvkontakte/files/libkvkontakte-5.0.0-fix-warnings.patch
new file mode 100644
index 000000000000..36e107001d1b
--- /dev/null
+++ b/net-libs/libkvkontakte/files/libkvkontakte-5.0.0-fix-warnings.patch
@@ -0,0 +1,386 @@
+From ba1f7e7f7424df2bf96513c14f10d3cff47f48a4 Mon Sep 17 00:00:00 2001
+From: Pino Toscano <pino@kde.org>
+Date: Sat, 9 Sep 2017 15:20:05 +0200
+Subject: use Q_DECL_OVERRIDE
+
+---
+ src/albumlistjob.h | 2 +-
+ src/allmessageslistjob.h | 2 +-
+ src/allnoteslistjob.h | 2 +-
+ src/cidsnamesjob.h | 2 +-
+ src/createalbumjob.h | 2 +-
+ src/deletealbumjob.h | 2 +-
+ src/discussionslistjob.h | 2 +-
+ src/editalbumjob.h | 2 +-
+ src/friendlistjob.h | 2 +-
+ src/getapplicationpermissionsjob.h | 2 +-
+ src/getinfojob.h | 2 +-
+ src/getphotouploadserverjob.h | 4 ++--
+ src/getvariablejob.h | 2 +-
+ src/grouplistjob.h | 2 +-
+ src/messageslistjob.h | 2 +-
+ src/noteaddjob.h | 2 +-
+ src/notejob.h | 2 +-
+ src/noteslistjob.h | 2 +-
+ src/photojob.h | 2 +-
+ src/photolistjob.h | 2 +-
+ src/photopostjob.h | 2 +-
+ src/savephotojob.h | 2 +-
+ src/uploadphotosjob.h | 2 +-
+ src/userinfojob.h | 4 ++--
+ src/vkontaktejobs.h | 6 +++---
+ 25 files changed, 29 insertions(+), 29 deletions(-)
+
+diff --git a/src/albumlistjob.h b/src/albumlistjob.h
+index 0e91af0..70dc29e 100644
+--- a/src/albumlistjob.h
++++ b/src/albumlistjob.h
+@@ -38,7 +38,7 @@ public:
+ QList<AlbumInfo> list() const;
+
+ protected:
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ void handleItem(const QVariant &data);
+
+diff --git a/src/allmessageslistjob.h b/src/allmessageslistjob.h
+index e714526..4bf067c 100644
+--- a/src/allmessageslistjob.h
++++ b/src/allmessageslistjob.h
+@@ -44,7 +44,7 @@ public:
+ int filters = 0, int timeOffset = 0);
+ ~AllMessagesListJob();
+
+- virtual void start();
++ void start() Q_DECL_OVERRIDE;
+
+ QList<MessageInfoPtr> list() const;
+ int count() const;
+diff --git a/src/allnoteslistjob.h b/src/allnoteslistjob.h
+index 1228bb8..661107a 100644
+--- a/src/allnoteslistjob.h
++++ b/src/allnoteslistjob.h
+@@ -33,7 +33,7 @@ public:
+ AllNotesListJob(const QString &accessToken, int uid);
+ ~AllNotesListJob();
+
+- virtual void start();
++ void start() Q_DECL_OVERRIDE;
+
+ QList<NoteInfoPtr> list() const;
+ int count() const;
+diff --git a/src/cidsnamesjob.h b/src/cidsnamesjob.h
+index 9bd142c..c6878a1 100644
+--- a/src/cidsnamesjob.h
++++ b/src/cidsnamesjob.h
+@@ -40,7 +40,7 @@ public:
+ QMap<int, QString> names() const;
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/createalbumjob.h b/src/createalbumjob.h
+index 8d7ec17..09c68e9 100644
+--- a/src/createalbumjob.h
++++ b/src/createalbumjob.h
+@@ -40,7 +40,7 @@ public:
+ AlbumInfo album() const;
+
+ protected:
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/deletealbumjob.h b/src/deletealbumjob.h
+index ef1f001..84fcfb5 100644
+--- a/src/deletealbumjob.h
++++ b/src/deletealbumjob.h
+@@ -33,7 +33,7 @@ public:
+ DeleteAlbumJob(const QString &accessToken, int aid);
+
+ protected:
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/discussionslistjob.h b/src/discussionslistjob.h
+index 79e801a..63cd825 100644
+--- a/src/discussionslistjob.h
++++ b/src/discussionslistjob.h
+@@ -46,7 +46,7 @@ public:
+ int totalCount() const;
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ void handleItem(const QVariant &data);
+
+diff --git a/src/editalbumjob.h b/src/editalbumjob.h
+index d9d76b6..eb52fe4 100644
+--- a/src/editalbumjob.h
++++ b/src/editalbumjob.h
+@@ -36,7 +36,7 @@ public:
+ int comment_privacy = AlbumInfo::PRIVACY_UNKNOWN);
+
+ protected:
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/friendlistjob.h b/src/friendlistjob.h
+index 6a7de49..465a109 100644
+--- a/src/friendlistjob.h
++++ b/src/friendlistjob.h
+@@ -39,7 +39,7 @@ public:
+ QList<UserInfoPtr> list() const;
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/getapplicationpermissionsjob.h b/src/getapplicationpermissionsjob.h
+index 72b6759..4165a1b 100644
+--- a/src/getapplicationpermissionsjob.h
++++ b/src/getapplicationpermissionsjob.h
+@@ -35,7 +35,7 @@ public:
+ int permissions() const;
+
+ protected:
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/getinfojob.h b/src/getinfojob.h
+index 98df0db..19b8f31 100644
+--- a/src/getinfojob.h
++++ b/src/getinfojob.h
+@@ -38,7 +38,7 @@ public:
+ QVariantMap info();
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/getphotouploadserverjob.h b/src/getphotouploadserverjob.h
+index af65921..3a3e9b0 100644
+--- a/src/getphotouploadserverjob.h
++++ b/src/getphotouploadserverjob.h
+@@ -41,8 +41,8 @@ public:
+
+ protected:
+ static QString getMethod(enum UploadPhotosJob::Dest dest);
+- virtual void prepareQueryItems();
+- virtual void handleData(const QJsonValue &data);
++ void prepareQueryItems() Q_DECL_OVERRIDE;
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ UploadPhotosJob::Dest m_dest;
+diff --git a/src/getvariablejob.h b/src/getvariablejob.h
+index f80ceb7..5250c6e 100644
+--- a/src/getvariablejob.h
++++ b/src/getvariablejob.h
+@@ -41,7 +41,7 @@ public:
+ QVariant variable() const;
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/grouplistjob.h b/src/grouplistjob.h
+index 29628f3..d41e1dc 100644
+--- a/src/grouplistjob.h
++++ b/src/grouplistjob.h
+@@ -42,7 +42,7 @@ public:
+
+ protected:
+ GroupInfoPtr handleSingleData(const QVariant &data);
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/messageslistjob.h b/src/messageslistjob.h
+index 0f67360..091ef60 100644
+--- a/src/messageslistjob.h
++++ b/src/messageslistjob.h
+@@ -57,7 +57,7 @@ public:
+ int out() const;
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ void handleItem(const QVariant &data);
+
+diff --git a/src/noteaddjob.h b/src/noteaddjob.h
+index 84cc63f..6c37efb 100644
+--- a/src/noteaddjob.h
++++ b/src/noteaddjob.h
+@@ -41,7 +41,7 @@ public:
+ int nid() const;
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/notejob.h b/src/notejob.h
+index dfeefc2..340eaef 100644
+--- a/src/notejob.h
++++ b/src/notejob.h
+@@ -37,7 +37,7 @@ public:
+ NoteInfoPtr noteInfo();
+
+ protected:
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/noteslistjob.h b/src/noteslistjob.h
+index 3ea51a7..d36e0bf 100644
+--- a/src/noteslistjob.h
++++ b/src/noteslistjob.h
+@@ -49,7 +49,7 @@ protected:
+ * @brief Handles the data returned by the VkontakteGetJob
+ * @param data A JSON string containing the data.
+ */
+- virtual void handleData(const QVariant &data);
++ void handleData(const QVariant &data) Q_DECL_OVERRIDE;
+
+ void handleItem(const QVariant &data);
+
+diff --git a/src/photojob.h b/src/photojob.h
+index b8af5b3..b230c29 100644
+--- a/src/photojob.h
++++ b/src/photojob.h
+@@ -35,7 +35,7 @@ public:
+ PhotoJob(const QUrl &urlString);
+ ~PhotoJob();
+
+- virtual void start();
++ void start() Q_DECL_OVERRIDE;
+ QImage photo() const;
+
+ private Q_SLOTS:
+diff --git a/src/photolistjob.h b/src/photolistjob.h
+index 4b38a12..a0c868f 100644
+--- a/src/photolistjob.h
++++ b/src/photolistjob.h
+@@ -42,7 +42,7 @@ protected:
+ * @brief Handles the data returned by VkontakteJob
+ * @param data JSON value containing an array of photos.
+ */
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/photopostjob.h b/src/photopostjob.h
+index 712906d..1f7b2ec 100644
+--- a/src/photopostjob.h
++++ b/src/photopostjob.h
+@@ -43,7 +43,7 @@ public:
+ // files.size <= 5
+ PhotoPostJob(Vkontakte::UploadPhotosJob::Dest dest, const QUrl &url, const QStringList &files);
+
+- virtual void start();
++ void start() Q_DECL_OVERRIDE;
+ QVariantMap response() const;
+
+ protected:
+diff --git a/src/savephotojob.h b/src/savephotojob.h
+index af2a795..cd4ab85 100644
+--- a/src/savephotojob.h
++++ b/src/savephotojob.h
+@@ -46,7 +46,7 @@ public:
+ protected:
+ QString getMethod(Vkontakte::UploadPhotosJob::Dest dest);
+ void handleItem(const QJsonValue &item);
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ private:
+ UploadPhotosJob::Dest m_dest;
+diff --git a/src/uploadphotosjob.h b/src/uploadphotosjob.h
+index 461f62a..d9290c4 100644
+--- a/src/uploadphotosjob.h
++++ b/src/uploadphotosjob.h
+@@ -43,7 +43,7 @@ public:
+ const QStringList &files, bool saveBig, int aid, int gid = -1);
+ ~UploadPhotosJob();
+
+- virtual void start();
++ void start() Q_DECL_OVERRIDE;
+
+ QList<PhotoInfo> list() const;
+
+diff --git a/src/userinfojob.h b/src/userinfojob.h
+index 85e6b86..5090ab3 100644
+--- a/src/userinfojob.h
++++ b/src/userinfojob.h
+@@ -71,12 +71,12 @@ protected:
+ * @brief Handles the data returned by the VkontakteGetJob
+ * @param data A JSON string containing the data.
+ */
+- virtual void handleData(const QJsonValue &data);
++ void handleData(const QJsonValue &data) Q_DECL_OVERRIDE;
+
+ /**
+ * @brief Prepares m_queryItems by several addQueryItem calls
+ **/
+- virtual void prepareQueryItems();
++ void prepareQueryItems() Q_DECL_OVERRIDE;
+
+ private:
+ class Private;
+diff --git a/src/vkontaktejobs.h b/src/vkontaktejobs.h
+index 9429da8..af04aa9 100644
+--- a/src/vkontaktejobs.h
++++ b/src/vkontaktejobs.h
+@@ -38,7 +38,7 @@ class LIBKVKONTAKTE_EXPORT KJobWithSubjob : public KJob
+ {
+ protected:
+ /** Kill the currentjobs and its subjobs */
+- virtual bool doKill();
++ bool doKill() Q_DECL_OVERRIDE;
+
+ QPointer<KJob> m_job; /** Pointer to the running job */
+ };
+@@ -47,7 +47,7 @@ class LIBKVKONTAKTE_EXPORT KJobWithSubjobs : public KJob
+ {
+ protected:
+ /** Kill the currentjobs and its subjobs */
+- virtual bool doKill();
++ bool doKill() Q_DECL_OVERRIDE;
+
+ QList<KJob *> m_jobs; /** Pointers to running jobs */
+ };
+@@ -68,7 +68,7 @@ public:
+ * */
+ VkontakteJob(const QString &accessToken, const QString &method, bool httpPost = false);
+
+- virtual void start();
++ void start() Q_DECL_OVERRIDE;
+
+ enum JobErrorType { AuthenticationProblem = KJob::UserDefinedError + 42 };
+
+--
+cgit v1.1
diff --git a/net-libs/libkvkontakte/libkvkontakte-5.0.0.ebuild b/net-libs/libkvkontakte/libkvkontakte-5.0.0-r1.ebuild
index 9f64b55ba18a..db21496fe470 100644
--- a/net-libs/libkvkontakte/libkvkontakte-5.0.0.ebuild
+++ b/net-libs/libkvkontakte/libkvkontakte-5.0.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
KDE_TEST="true"
inherit kde5
@@ -22,10 +22,12 @@ DEPEND="
$(add_frameworks_dep kwidgetsaddons)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
- $(add_qt_dep qtwebkit)
$(add_qt_dep qtwidgets)
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
"
RDEPEND="${DEPEND}"
# accessing network
RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-fix-warnings.patch" )