summaryrefslogtreecommitdiff
path: root/net-libs/libgfbgraph
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libgfbgraph')
-rw-r--r--net-libs/libgfbgraph/Manifest2
-rw-r--r--net-libs/libgfbgraph/libgfbgraph-0.2.4.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/net-libs/libgfbgraph/Manifest b/net-libs/libgfbgraph/Manifest
index bdf8577a6968..92522e4f574b 100644
--- a/net-libs/libgfbgraph/Manifest
+++ b/net-libs/libgfbgraph/Manifest
@@ -1,3 +1,5 @@
DIST gfbgraph-0.2.3.tar.xz 270772 BLAKE2B 4e9e1d9ed5d0bc58d6b01f6d58d7d9dc8cddb28c09bc820927e242a7d6118aabc8e4d808050205cf2d516571c598a0dbc75e09588e64d53db1456d519d23b810 SHA512 4e03beb4172a591c7d1eb4cfac56009b0d25183168f73344d24ac47554334d1edf2c5087c523025cee5d565182a02dc7ef72adc66cff1e4ad53a1d0990d3afb8
+DIST gfbgraph-0.2.4.tar.xz 39520 BLAKE2B 71ce5a091b5ab7d27b7b5353ff76cb67c90a358371f1afe41a561bab195c7e01353854fbd28c3970c3179ded24daf41f7150f70b5efcb1c81aac89de9fed2c88 SHA512 e6d63e56f4d67b59b0abbfb9dfe3aad8b142023413246015a84078c76f631eaa6e9fa7eb5771f64156ea01e160eb07b17783059e449036b372b4bcb26751ff68
EBUILD libgfbgraph-0.2.3-r1.ebuild 1005 BLAKE2B 8ffb8d2eec96a712eaa1ee1041e392edefe989d7915e753ecd9f52bb914dbbe0fbea18358d950aabab248960c17bba8d6eab3917f9040b039595a0518311a71e SHA512 d1d34aaf526c849097384343fbd9a8dab1400b93ebcb913ca348a376374aba0d356f61a0fb75bedc6dc595926148155cf05455606136594288ce0386dbe767d0
+EBUILD libgfbgraph-0.2.4.ebuild 1243 BLAKE2B 39b30bc1ad7f7cadcae0e486ff2194b84be4bd2bf5dbd5ca6d9afae2b543cf4c1c35dc26c9655cb68352aa74162474882aefc3d430d08caee7150a8f13135670 SHA512 54e129a0a37c3119a06a1b8652766695c266589e49d4c105c6f904e90ab708f622443a2dbbef02b0b35f5bc55168939f0574318554ddc3dbb56eddb7a8626e81
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/net-libs/libgfbgraph/libgfbgraph-0.2.4.ebuild b/net-libs/libgfbgraph/libgfbgraph-0.2.4.ebuild
new file mode 100644
index 000000000000..25eaeeb87edf
--- /dev/null
+++ b/net-libs/libgfbgraph/libgfbgraph-0.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gfbgraph"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="A GObject library for Facebook Graph API"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgfbgraph/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+introspection"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib[introspection?]
+ net-libs/libsoup:2.4[introspection?]
+ net-libs/gnome-online-accounts
+ net-libs/rest:0.7[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gtk-doc
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+# gtk-doc needed for autoreconf
+
+src_prepare() {
+ # Test requires a credentials.ini file.
+ # https://gitlab.gnome.org/GNOME/libgfbgraph/-/issues/7#note_802926
+ sed -i -e 's:TESTS = gtestutils:TESTS =:' tests/Makefile.am || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+ # Remove files installed in the wrong place
+ # Also, already done by portage
+ # https://bugzilla.gnome.org/show_bug.cgi?id=752581
+ rm -rf "${ED}"/usr/doc
+}