summaryrefslogtreecommitdiff
path: root/net-libs/libblkmaker/libblkmaker-0.6.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libblkmaker/libblkmaker-0.6.0-r1.ebuild')
-rw-r--r--net-libs/libblkmaker/libblkmaker-0.6.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/libblkmaker/libblkmaker-0.6.0-r1.ebuild b/net-libs/libblkmaker/libblkmaker-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..96ad5efcab6b
--- /dev/null
+++ b/net-libs/libblkmaker/libblkmaker-0.6.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C implementation of Bitcoin's getblocktemplate interface"
+HOMEPAGE="https://github.com/bitcoin/libblkmaker"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/bitcoin/${PN}/archive/v${PV}.tar.gz -> ${P}-github.tgz"
+SLOT="0/7"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/jansson-2.0.0:=[${MULTILIB_USEDEP}]
+ dev-libs/libbase58[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/libgcrypt[${MULTILIB_USEDEP}] )
+"
+
+ECONF_SOURCE="${S}"
+
+src_prepare() {
+ default
+ eautoreconf
+}