summaryrefslogtreecommitdiff
path: root/net-libs/ldns/ldns-1.7.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ldns/ldns-1.7.1-r2.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.7.1-r2.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-libs/ldns/ldns-1.7.1-r2.ebuild b/net-libs/ldns/ldns-1.7.1-r2.ebuild
index 9e872b955a93..ee8acea2dae4 100644
--- a/net-libs/ldns/ldns-1.7.1-r2.ebuild
+++ b/net-libs/ldns/ldns-1.7.1-r2.ebuild
@@ -12,28 +12,25 @@ SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa ed25519 ed448 gost libressl python static-libs vim-syntax"
+IUSE="+dane doc +ecdsa ed25519 ed448 gost python static-libs vim-syntax"
# configure will die if ecdsa is enabled and ssl is not
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
- ed25519? ( !libressl )
- ed448? ( !libressl )
"
RDEPEND="
python? ( ${PYTHON_DEPS} )
ecdsa? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}]
)
ed25519? (
- !libressl? ( >=dev-libs/openssl-1.1.0:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.1.0:0=[-bindist,${MULTILIB_USEDEP}]
)
ed448? (
- !libressl? ( >=dev-libs/openssl-1.1.1:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.1.1:0=[-bindist,${MULTILIB_USEDEP}]
)
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
python? ( dev-lang/swig )
@@ -52,7 +49,7 @@ pkg_setup() {
multilib_src_configure() {
# >=openssl-1.1.0 required for dane-ta
- if has_version "<dev-libs/openssl-1.1.0" || use libressl; then
+ if has_version "<dev-libs/openssl-1.1.0"; then
local dane_ta_usage="--disable-dane-ta-usage"
else
local dane_ta_usage=""