summaryrefslogtreecommitdiff
path: root/net-libs/ignition-transport
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ignition-transport')
-rw-r--r--net-libs/ignition-transport/Manifest5
-rw-r--r--net-libs/ignition-transport/files/zmq.patch31
-rw-r--r--net-libs/ignition-transport/ignition-transport-8.1.0.ebuild (renamed from net-libs/ignition-transport/ignition-transport-8.0.0.ebuild)9
3 files changed, 6 insertions, 39 deletions
diff --git a/net-libs/ignition-transport/Manifest b/net-libs/ignition-transport/Manifest
index ed97df92c2f4..b21d1c134e69 100644
--- a/net-libs/ignition-transport/Manifest
+++ b/net-libs/ignition-transport/Manifest
@@ -1,4 +1,3 @@
-AUX zmq.patch 1378 BLAKE2B 4fd868bc3d791e2f17fec392f8cdc5a6ce076b96453c35da46e8717e7274f29aa323dfc1985e819c49b587963b22813d4eb11b685d24c417d67720a7c5e3ac84 SHA512 9128f976e51dd333d856c15f1899955ff4879db229a174839be8e6d8c464cd7e0932c58098bcd1aa2e45fefdf5527bbe8a301306ddc75c022bc1fc0fd4ea9edc
-DIST ignition-transport8_8.0.0.tar.gz 543654 BLAKE2B 6f4154795d1f4708ad22d19fa573aeafe05710b280ea033d3fe92e50cf7e2426022ea5e98dd3a966dfe9a8b4765fa879050303fe11171a6586294facf7c278aa SHA512 ab1bae994a8676864ceb78b87f2258b8ed22036aed87e815fc22f830edd8b087d1ef0406dc0d053ea823d95b5fb765c4867d27ce5653f1d685001aab0cf0ec03
-EBUILD ignition-transport-8.0.0.ebuild 813 BLAKE2B 6f25224233eac67cd25e873a94e943bc5ff6fae13852cd1b6f0997f773c5abf04833b763921ff1f3d0ee9687483f21f5ff2e8fddc8a4779a5b50fc4c189f6187 SHA512 71d668c92c9b1347a0b2b1444b3a1499065589ea590643f53688c529d2a5c7cf7e8c40f6f78cd2e235da476e4a2b2948ab3f1c7a0278e6d32d4ee24604b2ae90
+DIST ignition-transport8_8.1.0.tar.gz 663459 BLAKE2B aa3acbf280b6ebdfc7a734521df4edf8724fe24cf92de81e4dd5bf33d65257c929417af205a44b731a878111a3586fef1e9d5b27df0b7343e402424108a22598 SHA512 eb64f18721190fcb79a5b45746fd44fa24274c6fe6c5021dd9306c15a327873377d07d4aa770633982038b84da650d3d0c8a56169222c0c88fa1318314fc4529
+EBUILD ignition-transport-8.1.0.ebuild 753 BLAKE2B 56dde2027f48a66e3ec135eee7f5bd7942e430638094be1d5fc8362f1474c8d727bb10256b49401a7b69644810b35c274c64b5d5bc196916b619f730cac9e251 SHA512 59de2d437f25fa6aff901653b87c696ce30e316fd808ac7241401a7b5f2dd912c9f3502929613564b9d098150f6006c6eed19782ecf492ff58bf4969d7895311
MISC metadata.xml 243 BLAKE2B 13c40383778472fec33f877963b2be8d44c354e5449e3ac38dfba06cb38e4cfb6a63d5d73c5acb1e02a1c8ee783131c46c8b56eb14de786de7f77635f15d18d7 SHA512 c9d5c1cdd2874fe293f21f7584c6e15ef9439bd82b0d2e862e3e34c9a9e0e3191370fee2727b9d4d8647fb85cf56a39fdd6c1e0003ada1554496aad311ef335c
diff --git a/net-libs/ignition-transport/files/zmq.patch b/net-libs/ignition-transport/files/zmq.patch
deleted file mode 100644
index ddbf8f113064..000000000000
--- a/net-libs/ignition-transport/files/zmq.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: ignition-transport4-4.0.0/src/NodeShared.cc
-===================================================================
---- ignition-transport4-4.0.0.orig/src/NodeShared.cc
-+++ ignition-transport4-4.0.0/src/NodeShared.cc
-@@ -92,7 +92,8 @@ bool userPass(std::string &_user, std::s
- // Helper to send messages
- int sendHelper(zmq::socket_t &_pub, const std::string &_data, int _type)
- {
-- zmq::message_t msg(_data.data(), _data.size());
-+ zmq::message_t msg(_data.size());
-+ memcpy(msg.data(), _data.data(), _data.size());
- return _pub.send(msg, _type);
- }
-
-@@ -278,10 +279,13 @@ bool NodeShared::Publish(
- {
- // Create the messages.
- // Note that we use zero copy for passing the message data (msg2).
-- zmq::message_t msg0(_topic.data(), _topic.size()),
-- msg1(this->myAddress.data(), this->myAddress.size()),
-+ zmq::message_t msg0(_topic.size()),
-+ msg1(this->myAddress.size()),
- msg2(_data, _dataSize, _ffn, nullptr),
-- msg3(_msgType.data(), _msgType.size());
-+ msg3(_msgType.size());
-+ memcpy(msg0.data(), _topic.data(), _topic.size());
-+ memcpy(msg1.data(), this->myAddress.data(), this->myAddress.size());
-+ memcpy(msg3.data(), _msgType.data(), _msgType.size());
-
- // Send the messages
- std::lock_guard<std::recursive_mutex> lock(this->mutex);
diff --git a/net-libs/ignition-transport/ignition-transport-8.0.0.ebuild b/net-libs/ignition-transport/ignition-transport-8.1.0.ebuild
index 9e15e8e7f1ab..7adee87f2cc8 100644
--- a/net-libs/ignition-transport/ignition-transport-8.0.0.ebuild
+++ b/net-libs/ignition-transport/ignition-transport-8.1.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
-DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
-HOMEPAGE="https://ignitionrobotics.org/libraries/transport"
+DESCRIPTION="Combines ZeroMQ with Protobufs to create a message passing system"
+HOMEPAGE="https://github.com/ignitionrobotics/ign-transport"
SRC_URI="https://github.com/ignitionrobotics/ign-transport/archive/${PN}8_${PV}.tar.gz"
LICENSE="Apache-2.0"
@@ -30,4 +30,3 @@ BDEPEND="
virtual/pkgconfig"
CMAKE_BUILD_TYPE=RelWithDebInfo
S="${WORKDIR}/ign-transport-${PN}8_${PV}"
-PATCHES=( "${FILESDIR}/zmq.patch" )