summaryrefslogtreecommitdiff
path: root/net-libs/gsnmp/gsnmp-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gsnmp/gsnmp-0.3.0.ebuild')
-rw-r--r--net-libs/gsnmp/gsnmp-0.3.0.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/net-libs/gsnmp/gsnmp-0.3.0.ebuild b/net-libs/gsnmp/gsnmp-0.3.0.ebuild
index 346fa6711278..03183265f562 100644
--- a/net-libs/gsnmp/gsnmp-0.3.0.ebuild
+++ b/net-libs/gsnmp/gsnmp-0.3.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils ltprune
+EAPI=7
+
+inherit autotools
DESCRIPTION="An SNMP library based on glib and gnet"
HOMEPAGE="https://github.com/schoenw/gsnmp"
@@ -18,14 +19,18 @@ DEPEND="
net-libs/gnet
"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README )
-DOCS="README"
+PATCHES=(
+ "${FILESDIR}"/${P}-g_access.patch
+ "${FILESDIR}"/${P}-pkg_config.patch
+ "${FILESDIR}"/${P}-underquoting.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-g_access.patch \
- "${FILESDIR}"/${P}-pkg_config.patch \
- "${FILESDIR}"/${P}-underquoting.patch
+ default
eautoreconf
}
@@ -37,5 +42,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}