summaryrefslogtreecommitdiff
path: root/net-libs/grpc/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/grpc/files')
-rw-r--r--net-libs/grpc/files/0001-grpc-1.11.0-Fix-cross-compiling.patch58
-rw-r--r--net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch38
-rw-r--r--net-libs/grpc/files/0004-grpc-1.11.0-fix-cpp-so-version.patch49
-rw-r--r--net-libs/grpc/files/0006-grpc-1.12.1-allow-system-openssl.patch65
-rw-r--r--net-libs/grpc/files/0007-grpc-1.12.1-allow-system-zlib.patch52
-rw-r--r--net-libs/grpc/files/0008-grpc-1.12.1-allow-system-cares.patch52
-rw-r--r--net-libs/grpc/files/0009-grpc-1.12.1-gcc8-fixes.patch53
-rw-r--r--net-libs/grpc/files/grpc-1.11.0-pkgconfig-libdir.patch (renamed from net-libs/grpc/files/0005-grpc-1.11.0-pkgconfig-libdir.patch)0
-rw-r--r--net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch (renamed from net-libs/grpc/files/0001-grpc-1.13.0-fix-host-ar-handling.patch)0
-rw-r--r--net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch83
-rw-r--r--net-libs/grpc/files/grpc-1.21.0-fix-host-ar-handling.patch (renamed from net-libs/grpc/files/1.21.0-fix-host-ar-handling.patch)0
-rw-r--r--net-libs/grpc/files/grpc-1.22.0-cxx_arg_list_too_long_forloop.patch (renamed from net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch)0
-rw-r--r--net-libs/grpc/files/grpc-1.3.0-Don-t-run-ldconfig.patch (renamed from net-libs/grpc/files/0003-grpc-1.3.0-Don-t-run-ldconfig.patch)0
13 files changed, 0 insertions, 450 deletions
diff --git a/net-libs/grpc/files/0001-grpc-1.11.0-Fix-cross-compiling.patch b/net-libs/grpc/files/0001-grpc-1.11.0-Fix-cross-compiling.patch
deleted file mode 100644
index 6c4767759b4d..000000000000
--- a/net-libs/grpc/files/0001-grpc-1.11.0-Fix-cross-compiling.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From b9e631dad111f725c1a4e8b69ff1960397a5cc22 Mon Sep 17 00:00:00 2001
-From: Chirantan Ekbote <chirantan@google.com>
-Date: Mon, 10 Jul 2017 13:19:35 -0700
-Subject: [PATCH 2/5] grpc-1.3.0: Fix cross-compiling
-
-Cross-compiling was severely broken in the Makefile. Fix it.
-
-Sent upstream as https://github.com/grpc/grpc/pull/11476.
----
- Makefile | 16 +++++++++-------
- 1 file changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 95de4f6530..4f0680e1d2 100644
---- a/Makefile
-+++ b/Makefile
-@@ -329,6 +329,7 @@ HOST_CC ?= $(CC)
- HOST_CXX ?= $(CXX)
- HOST_LD ?= $(LD)
- HOST_LDXX ?= $(LDXX)
-+HOST_AR ?= $(AR)
-
- CFLAGS += -std=c99 -Wsign-conversion -Wconversion $(W_SHADOW) $(W_EXTRA_SEMI)
- ifeq ($(HAS_CXX11),true)
-@@ -438,11 +439,12 @@ LDFLAGS += $(EXTRA_LDFLAGS)
- DEFINES += $(EXTRA_DEFINES)
- LDLIBS += $(EXTRA_LDLIBS)
-
--HOST_CPPFLAGS = $(CPPFLAGS)
--HOST_CFLAGS = $(CFLAGS)
--HOST_CXXFLAGS = $(CXXFLAGS)
--HOST_LDFLAGS = $(LDFLAGS)
--HOST_LDLIBS = $(LDLIBS)
-+HOST_CPPFLAGS = $(CPPFLAGS_NO_ARCH) -g -Wall -Wextra -Werror -Wno-long-long -Wno-unused-parameter -DOSATOMIC_USE_INLINED=1 -fPIC
-+HOST_CFLAGS = -std=c99 -Wsign-conversion -Wconversion $(W_SHADOW) $(W_EXTRA_SEMI)
-+HOST_CXXFLAGS = -std=c++11
-+HOST_LDFLAGS = -g -fPIC -Llibs/$(CONFIG)
-+HOST_LDLIBS = -lprotoc
-+HOST_AROPTS = $(AROPTS)
-
- # These are automatically computed variables.
- # There shouldn't be any need to change anything from now on.
-@@ -6838,10 +6840,10 @@ $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a: protobuf_dep_error
- else
-
- $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a: $(ZLIB_DEP) $(CARES_DEP) $(ADDRESS_SORTING_DEP) $(PROTOBUF_DEP) $(LIBGRPC_PLUGIN_SUPPORT_OBJS)
-- $(E) "[AR] Creating $@"
-+ $(E) "[HOSTAR] Creating $@"
- $(Q) mkdir -p `dirname $@`
- $(Q) rm -f $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a
-- $(Q) $(AR) $(AROPTS) $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a $(LIBGRPC_PLUGIN_SUPPORT_OBJS)
-+ $(Q) $(HOST_AR) $(HOST_AROPTS) $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a $(LIBGRPC_PLUGIN_SUPPORT_OBJS)
- ifeq ($(SYSTEM),Darwin)
- $(Q) ranlib -no_warning_for_no_symbols $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a
- endif
---
-2.14.0.rc0.284.gd933b75aa4-goog
-
diff --git a/net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch b/net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch
deleted file mode 100644
index e6bde1321a46..000000000000
--- a/net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From bc139f5b7ce6a2a6d7c67480a04e029955aec0ab Mon Sep 17 00:00:00 2001
-From: Chirantan Ekbote <chirantan@google.com>
-Date: Mon, 10 Jul 2017 13:21:27 -0700
-Subject: [PATCH 3/5] grpc-1.3.0: Fix unsecure .pc files
-
-The *_unsecure.pc files were still linking against the secure versions
-of the grpc libraries. Fix them to link against the unsecure versions.
-
-Sent upstream as https://github.com/grpc/grpc/pull/11448.
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 4f0680e1d2..86bd66a5e0 100644
---- a/Makefile
-+++ b/Makefile
-@@ -778,7 +778,7 @@ PC_DESCRIPTION = high performance general RPC framework without SSL
- PC_CFLAGS =
- PC_REQUIRES_PRIVATE = $(PC_REQUIRES_GRPC)
- PC_LIBS_PRIVATE = $(PC_LIBS_GRPC)
--PC_LIB = -lgrpc
-+PC_LIB = -lgrpc_unsecure
- GRPC_UNSECURE_PC_FILE := $(CORE_PC_TEMPLATE)
-
- PROTOBUF_PKG_CONFIG = false
-@@ -849,7 +849,7 @@ PC_DESCRIPTION = C++ wrapper for gRPC without SSL
- PC_CFLAGS =
- PC_REQUIRES_PRIVATE = grpc_unsecure $(PC_REQUIRES_GRPCXX)
- PC_LIBS_PRIVATE = $(PC_LIBS_GRPCXX)
--PC_LIB = -lgrpc++
-+PC_LIB = -lgrpc++_unsecure
- GRPCXX_UNSECURE_PC_FILE := $(CPP_PC_TEMPLATE)
-
- ifeq ($(MAKECMDGOALS),clean)
---
-2.14.0.rc0.284.gd933b75aa4-goog
-
diff --git a/net-libs/grpc/files/0004-grpc-1.11.0-fix-cpp-so-version.patch b/net-libs/grpc/files/0004-grpc-1.11.0-fix-cpp-so-version.patch
deleted file mode 100644
index 465520257cf6..000000000000
--- a/net-libs/grpc/files/0004-grpc-1.11.0-fix-cpp-so-version.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-It creates the symlinks with the wrong versions
-
---- a/Makefile.orig 2018-05-02 14:19:10.007775576 +0800
-+++ b/Makefile 2018-05-02 14:20:59.414089065 +0800
-@@ -2928,7 +2928,7 @@
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -2937,7 +2937,7 @@
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_cronet$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -2946,7 +2946,7 @@
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_error_details$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -2955,7 +2955,7 @@
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_reflection$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -2964,7 +2964,7 @@
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_unsecure$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.so
- endif
- ifneq ($(SYSTEM),MINGW32)
diff --git a/net-libs/grpc/files/0006-grpc-1.12.1-allow-system-openssl.patch b/net-libs/grpc/files/0006-grpc-1.12.1-allow-system-openssl.patch
deleted file mode 100644
index 61fd830d64d4..000000000000
--- a/net-libs/grpc/files/0006-grpc-1.12.1-allow-system-openssl.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From 30ce693621d61efb8596503a0da212077a8c4daa Mon Sep 17 00:00:00 2001
-From: Thomas Bechtold <tbechtold@suse.com>
-Date: Thu, 24 May 2018 17:12:13 +0200
-Subject: [PATCH] Allow building the python module with system openssl
-
-When building the python module and using the new
-GRPC_PYTHON_BUILD_SYSTEM_OPENSSL env variable, the third party
-boringssl code is not compiled. Instead, the openssl shared library
-installed on the system is used during runtime.
-This is useful for distributions who don't want to include code copies
-but use shared libraries instead.
----
- setup.py | 17 +++++++++++++++--
- 1 file changed, 15 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 99d1a1c504e..3a5ed56c641 100644
---- a/setup.py
-+++ b/setup.py
-@@ -35,7 +35,7 @@
- PY3 = sys.version_info.major == 3
- PYTHON_STEM = os.path.join('src', 'python', 'grpcio')
- CORE_INCLUDE = ('include', '.',)
--BORINGSSL_INCLUDE = (os.path.join('third_party', 'boringssl', 'include'),)
-+SSL_INCLUDE = (os.path.join('third_party', 'boringssl', 'include'),)
- ZLIB_INCLUDE = (os.path.join('third_party', 'zlib'),)
- CARES_INCLUDE = (
- os.path.join('third_party', 'cares'),
-@@ -84,6 +84,12 @@
- # present, then it will still attempt to use Cython.
- BUILD_WITH_CYTHON = os.environ.get('GRPC_PYTHON_BUILD_WITH_CYTHON', False)
-
-+# Export this variable to use the system installation of openssl. You need to
-+# have the header files installed (in /usr/include/openssl) and during
-+# runtime, the shared libary must be installed
-+BUILD_WITH_SYSTEM_OPENSSL = os.environ.get('GRPC_PYTHON_BUILD_SYSTEM_OPENSSL',
-+ False)
-+
- # Environment variable to determine whether or not to enable coverage analysis
- # in Cython modules.
- ENABLE_CYTHON_TRACING = os.environ.get(
-@@ -148,8 +154,13 @@
- if "win32" in sys.platform:
- CORE_C_FILES = filter(lambda x: 'third_party/cares' not in x, CORE_C_FILES)
-
-+if BUILD_WITH_SYSTEM_OPENSSL:
-+ CORE_C_FILES = filter(lambda x: 'third_party/boringssl' not in x, CORE_C_FILES)
-+ CORE_C_FILES = filter(lambda x: 'src/boringssl' not in x, CORE_C_FILES)
-+ SSL_INCLUDE = (os.path.join('/usr', 'include', 'openssl'),)
-+
- EXTENSION_INCLUDE_DIRECTORIES = (
-- (PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE + ZLIB_INCLUDE +
-+ (PYTHON_STEM,) + CORE_INCLUDE + SSL_INCLUDE + ZLIB_INCLUDE +
- CARES_INCLUDE + ADDRESS_SORTING_INCLUDE)
-
- EXTENSION_LIBRARIES = ()
-@@ -159,6 +170,8 @@
- EXTENSION_LIBRARIES += ('m',)
- if "win32" in sys.platform:
- EXTENSION_LIBRARIES += ('advapi32', 'ws2_32',)
-+if BUILD_WITH_SYSTEM_OPENSSL:
-+ EXTENSION_LIBRARIES += ('ssl', 'crypto',)
-
- DEFINE_MACROS = (
- ('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600),
diff --git a/net-libs/grpc/files/0007-grpc-1.12.1-allow-system-zlib.patch b/net-libs/grpc/files/0007-grpc-1.12.1-allow-system-zlib.patch
deleted file mode 100644
index 6964642b119d..000000000000
--- a/net-libs/grpc/files/0007-grpc-1.12.1-allow-system-zlib.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 3823d9048102bce79e165584c62a1a5b91810aeb Mon Sep 17 00:00:00 2001
-From: Thomas Bechtold <tbechtold@suse.com>
-Date: Fri, 25 May 2018 06:52:23 +0200
-Subject: [PATCH] Allow building the python module with system zlib
-
-When building the python module and using the new
-GRPC_PYTHON_BUILD_SYSTEM_ZLIB env variable, the third party zlib code
-is not compiled. Instead, the zlib shared library installed on the
-system is used during runtime.
-This is useful for distributions who don't want to include code copies
-but use shared libraries instead.
----
- setup.py | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/setup.py b/setup.py
-index 3a5ed56c641..483d3ac1682 100644
---- a/setup.py
-+++ b/setup.py
-@@ -90,6 +90,12 @@
- BUILD_WITH_SYSTEM_OPENSSL = os.environ.get('GRPC_PYTHON_BUILD_SYSTEM_OPENSSL',
- False)
-
-+# Export this variable to use the system installation of zlib. You need to
-+# have the header files installed (in /usr/include/) and during
-+# runtime, the shared libary must be installed
-+BUILD_WITH_SYSTEM_ZLIB = os.environ.get('GRPC_PYTHON_BUILD_SYSTEM_ZLIB',
-+ False)
-+
- # Environment variable to determine whether or not to enable coverage analysis
- # in Cython modules.
- ENABLE_CYTHON_TRACING = os.environ.get(
-@@ -159,6 +165,10 @@
- CORE_C_FILES = filter(lambda x: 'src/boringssl' not in x, CORE_C_FILES)
- SSL_INCLUDE = (os.path.join('/usr', 'include', 'openssl'),)
-
-+if BUILD_WITH_SYSTEM_ZLIB:
-+ CORE_C_FILES = filter(lambda x: 'third_party/zlib' not in x, CORE_C_FILES)
-+ ZLIB_INCLUDE = (os.path.join('/usr', 'include'),)
-+
- EXTENSION_INCLUDE_DIRECTORIES = (
- (PYTHON_STEM,) + CORE_INCLUDE + SSL_INCLUDE + ZLIB_INCLUDE +
- CARES_INCLUDE + ADDRESS_SORTING_INCLUDE)
-@@ -172,6 +182,8 @@
- EXTENSION_LIBRARIES += ('advapi32', 'ws2_32',)
- if BUILD_WITH_SYSTEM_OPENSSL:
- EXTENSION_LIBRARIES += ('ssl', 'crypto',)
-+if BUILD_WITH_SYSTEM_ZLIB:
-+ EXTENSION_LIBRARIES += ('z',)
-
- DEFINE_MACROS = (
- ('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600),
diff --git a/net-libs/grpc/files/0008-grpc-1.12.1-allow-system-cares.patch b/net-libs/grpc/files/0008-grpc-1.12.1-allow-system-cares.patch
deleted file mode 100644
index c2e20f3994f4..000000000000
--- a/net-libs/grpc/files/0008-grpc-1.12.1-allow-system-cares.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 78a6e04ec1efc2dc839f0329dcff732940e27fd9 Mon Sep 17 00:00:00 2001
-From: Thomas Bechtold <tbechtold@suse.com>
-Date: Fri, 25 May 2018 07:08:05 +0200
-Subject: [PATCH] Allow building the python module with system cares
-
-When building the python module and using the new
-GRPC_PYTHON_BUILD_SYSTEM_CARES env variable, the third party cares code
-is not compiled. Instead, the cares shared library installed on the
-system is used during runtime.
-This is useful for distributions who don't want to include code copies
-but use shared libraries instead.
----
- setup.py | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/setup.py b/setup.py
-index 483d3ac1682..43c25aafeb9 100644
---- a/setup.py
-+++ b/setup.py
-@@ -96,6 +96,12 @@
- BUILD_WITH_SYSTEM_ZLIB = os.environ.get('GRPC_PYTHON_BUILD_SYSTEM_ZLIB',
- False)
-
-+# Export this variable to use the system installation of cares. You need to
-+# have the header files installed (in /usr/include/) and during
-+# runtime, the shared libary must be installed
-+BUILD_WITH_SYSTEM_CARES = os.environ.get('GRPC_PYTHON_BUILD_SYSTEM_CARES',
-+ False)
-+
- # Environment variable to determine whether or not to enable coverage analysis
- # in Cython modules.
- ENABLE_CYTHON_TRACING = os.environ.get(
-@@ -169,6 +175,10 @@
- CORE_C_FILES = filter(lambda x: 'third_party/zlib' not in x, CORE_C_FILES)
- ZLIB_INCLUDE = (os.path.join('/usr', 'include'),)
-
-+if BUILD_WITH_SYSTEM_CARES:
-+ CORE_C_FILES = filter(lambda x: 'third_party/cares' not in x, CORE_C_FILES)
-+ CARES_INCLUDE = (os.path.join('/usr', 'include'),)
-+
- EXTENSION_INCLUDE_DIRECTORIES = (
- (PYTHON_STEM,) + CORE_INCLUDE + SSL_INCLUDE + ZLIB_INCLUDE +
- CARES_INCLUDE + ADDRESS_SORTING_INCLUDE)
-@@ -184,6 +194,8 @@
- EXTENSION_LIBRARIES += ('ssl', 'crypto',)
- if BUILD_WITH_SYSTEM_ZLIB:
- EXTENSION_LIBRARIES += ('z',)
-+if BUILD_WITH_SYSTEM_CARES:
-+ EXTENSION_LIBRARIES += ('cares',)
-
- DEFINE_MACROS = (
- ('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600),
diff --git a/net-libs/grpc/files/0009-grpc-1.12.1-gcc8-fixes.patch b/net-libs/grpc/files/0009-grpc-1.12.1-gcc8-fixes.patch
deleted file mode 100644
index a9168f165e19..000000000000
--- a/net-libs/grpc/files/0009-grpc-1.12.1-gcc8-fixes.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- a/tmp/alts_transport_security.cc.ORIG 2018-04-13 20:08:11.000000000 +0200
-+++ b/src/core/tsi/alts_transport_security.cc 2018-05-20 16:54:49.995787548 +0200
-@@ -45,7 +45,7 @@
- }
-
- void grpc_tsi_alts_init() {
-- memset(&g_alts_resource, 0, sizeof(alts_shared_resource));
-+ memset((void*)&g_alts_resource, 0, sizeof(alts_shared_resource));
- gpr_mu_init(&g_alts_resource.mu);
- gpr_cv_init(&g_alts_resource.cv);
- }
---- a/tmp/client_channel.cc.ORIG 2018-04-13 20:08:11.000000000 +0200
-+++ b/src/core/ext/filters/client_channel/client_channel.cc 2018-05-20 17:07:20.604746186 +0200
-@@ -416,7 +416,7 @@
- grpc_uri* uri = grpc_uri_parse(server_uri, true);
- GPR_ASSERT(uri->path[0] != '\0');
- service_config_parsing_state parsing_state;
-- memset(&parsing_state, 0, sizeof(parsing_state));
-+ memset((void*)&parsing_state, 0, sizeof(parsing_state));
- parsing_state.server_name =
- uri->path[0] == '/' ? uri->path + 1 : uri->path;
- service_config->ParseGlobalParams(parse_retry_throttle_params,
---- a/tmp/channel.cc.ORIG 2018-04-13 20:08:11.000000000 +0200
-+++ b/src/core/lib/surface/channel.cc 2018-05-20 16:58:01.632776988 +0200
-@@ -103,7 +103,7 @@
- return channel;
- }
-
-- memset(channel, 0, sizeof(*channel));
-+ memset((void*)channel, 0, sizeof(*channel));
- channel->target = target;
- channel->is_client = grpc_channel_stack_type_is_client(channel_stack_type);
- size_t channel_tracer_max_nodes = 0; // default to off
-@@ -280,7 +280,7 @@
- }
-
- grpc_call_create_args args;
-- memset(&args, 0, sizeof(args));
-+ memset((void*)&args, 0, sizeof(args));
- args.channel = channel;
- args.parent = parent_call;
- args.propagation_mask = propagation_mask;
---- a/tmp/flow_control.cc.ORIG 2018-04-13 20:08:11.000000000 +0200
-+++ b/src/core/ext/transport/chttp2/transport/flow_control.cc 2018-05-20 17:09:47.055738116 +0200
-@@ -187,7 +187,7 @@
- uint32_t TransportFlowControl::MaybeSendUpdate(bool writing_anyway) {
- FlowControlTrace trace("t updt sent", this, nullptr);
- const uint32_t target_announced_window =
-- static_cast<const uint32_t>(target_window());
-+ static_cast<uint32_t>(target_window());
- if ((writing_anyway || announced_window_ <= target_announced_window / 2) &&
- announced_window_ != target_announced_window) {
- const uint32_t announce = static_cast<uint32_t> GPR_CLAMP(
diff --git a/net-libs/grpc/files/0005-grpc-1.11.0-pkgconfig-libdir.patch b/net-libs/grpc/files/grpc-1.11.0-pkgconfig-libdir.patch
index 257bef8aa140..257bef8aa140 100644
--- a/net-libs/grpc/files/0005-grpc-1.11.0-pkgconfig-libdir.patch
+++ b/net-libs/grpc/files/grpc-1.11.0-pkgconfig-libdir.patch
diff --git a/net-libs/grpc/files/0001-grpc-1.13.0-fix-host-ar-handling.patch b/net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch
index 926952f47f2a..926952f47f2a 100644
--- a/net-libs/grpc/files/0001-grpc-1.13.0-fix-host-ar-handling.patch
+++ b/net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch
diff --git a/net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch b/net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch
deleted file mode 100644
index cb61b5f26fee..000000000000
--- a/net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 9c7db45da9a6ddc5d65cd19704539579eb31d2ce Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Wed, 12 Sep 2018 10:35:45 -0700
-Subject: [PATCH] Fix failures with gcc-8
-
-Based on this PR https://github.com/grpc/grpc/pull/15443
----
- src/core/ext/filters/client_channel/client_channel.cc | 2 +-
- .../client_channel/lb_policy/grpclb/load_balancer_api.cc | 3 ++-
- src/core/ext/transport/chttp2/transport/flow_control.cc | 2 +-
- src/core/lib/surface/channel.cc | 2 +-
- src/core/tsi/alts_transport_security.cc | 2 +-
- 5 files changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/src/core/ext/filters/client_channel/client_channel.cc b/src/core/ext/filters/client_channel/client_channel.cc
-index d2bf4f388d..503fb1ac87 100644
---- a/src/core/ext/filters/client_channel/client_channel.cc
-+++ b/src/core/ext/filters/client_channel/client_channel.cc
-@@ -457,7 +457,7 @@ get_service_config_from_resolver_result_locked(channel_data* chand) {
- grpc_uri* uri = grpc_uri_parse(server_uri, true);
- GPR_ASSERT(uri->path[0] != '\0');
- service_config_parsing_state parsing_state;
-- memset(&parsing_state, 0, sizeof(parsing_state));
-+ memset(reinterpret_cast<void *>(&parsing_state), 0, sizeof(parsing_state));
- parsing_state.server_name =
- uri->path[0] == '/' ? uri->path + 1 : uri->path;
- service_config->ParseGlobalParams(parse_retry_throttle_params,
-diff --git a/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc b/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
-index f24281a5bf..74baf430f1 100644
---- a/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
-+++ b/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
-@@ -68,7 +68,8 @@ grpc_grpclb_request* grpc_grpclb_request_create(const char* lb_service_name) {
- req->has_initial_request = true;
- req->initial_request.has_name = true;
- strncpy(req->initial_request.name, lb_service_name,
-- GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH);
-+ GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH-1);
-+ req->initial_request.name[GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH] = '\0';
- return req;
- }
-
-diff --git a/src/core/ext/transport/chttp2/transport/flow_control.cc b/src/core/ext/transport/chttp2/transport/flow_control.cc
-index 53932bcb7f..4b1862735d 100644
---- a/src/core/ext/transport/chttp2/transport/flow_control.cc
-+++ b/src/core/ext/transport/chttp2/transport/flow_control.cc
-@@ -190,7 +190,7 @@ TransportFlowControl::TransportFlowControl(const grpc_chttp2_transport* t,
- uint32_t TransportFlowControl::MaybeSendUpdate(bool writing_anyway) {
- FlowControlTrace trace("t updt sent", this, nullptr);
- const uint32_t target_announced_window =
-- static_cast<const uint32_t>(target_window());
-+ static_cast<uint32_t>(target_window());
- if ((writing_anyway || announced_window_ <= target_announced_window / 2) &&
- announced_window_ != target_announced_window) {
- const uint32_t announce = static_cast<uint32_t> GPR_CLAMP(
-diff --git a/src/core/lib/surface/channel.cc b/src/core/lib/surface/channel.cc
-index 82635d3c21..f9d89657b3 100644
---- a/src/core/lib/surface/channel.cc
-+++ b/src/core/lib/surface/channel.cc
-@@ -100,7 +100,7 @@ grpc_channel* grpc_channel_create_with_builder(
- return channel;
- }
-
-- memset(channel, 0, sizeof(*channel));
-+ memset(reinterpret_cast<void *>(channel), 0, sizeof(*channel));
- channel->target = target;
- channel->is_client = grpc_channel_stack_type_is_client(channel_stack_type);
- size_t channel_tracer_max_nodes = 0; // default to off
-diff --git a/src/core/tsi/alts_transport_security.cc b/src/core/tsi/alts_transport_security.cc
-index 2fd408103b..51f9e9e85b 100644
---- a/src/core/tsi/alts_transport_security.cc
-+++ b/src/core/tsi/alts_transport_security.cc
-@@ -45,7 +45,7 @@ void grpc_tsi_alts_signal_for_cq_destroy() {
- }
-
- void grpc_tsi_alts_init() {
-- memset(&g_alts_resource, 0, sizeof(alts_shared_resource));
-+ memset(reinterpret_cast<void *>(&g_alts_resource), 0, sizeof(alts_shared_resource));
- gpr_mu_init(&g_alts_resource.mu);
- gpr_cv_init(&g_alts_resource.cv);
- }
---
-2.18.0
-
diff --git a/net-libs/grpc/files/1.21.0-fix-host-ar-handling.patch b/net-libs/grpc/files/grpc-1.21.0-fix-host-ar-handling.patch
index 213a39a38438..213a39a38438 100644
--- a/net-libs/grpc/files/1.21.0-fix-host-ar-handling.patch
+++ b/net-libs/grpc/files/grpc-1.21.0-fix-host-ar-handling.patch
diff --git a/net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch b/net-libs/grpc/files/grpc-1.22.0-cxx_arg_list_too_long_forloop.patch
index 974d6fcc4351..974d6fcc4351 100644
--- a/net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch
+++ b/net-libs/grpc/files/grpc-1.22.0-cxx_arg_list_too_long_forloop.patch
diff --git a/net-libs/grpc/files/0003-grpc-1.3.0-Don-t-run-ldconfig.patch b/net-libs/grpc/files/grpc-1.3.0-Don-t-run-ldconfig.patch
index d18063f2ef1b..d18063f2ef1b 100644
--- a/net-libs/grpc/files/0003-grpc-1.3.0-Don-t-run-ldconfig.patch
+++ b/net-libs/grpc/files/grpc-1.3.0-Don-t-run-ldconfig.patch