summaryrefslogtreecommitdiff
path: root/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/dleyna-core/dleyna-core-0.7.0.ebuild')
-rw-r--r--net-libs/dleyna-core/dleyna-core-0.7.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild b/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
new file mode 100644
index 000000000000..119dfa74760a
--- /dev/null
+++ b/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="utility library for higher level dLeyna libraries"
+HOMEPAGE="https://github.com/phako/dleyna-core"
+SRC_URI="https://github.com/phako/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/5" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gupnp-1.2.0:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"