summaryrefslogtreecommitdiff
path: root/net-libs/czmq/czmq-4.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/czmq/czmq-4.2.1.ebuild')
-rw-r--r--net-libs/czmq/czmq-4.2.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-libs/czmq/czmq-4.2.1.ebuild b/net-libs/czmq/czmq-4.2.1.ebuild
index 6b42355ba222..0e76450ec3f8 100644
--- a/net-libs/czmq/czmq-4.2.1.ebuild
+++ b/net-libs/czmq/czmq-4.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -10,7 +10,8 @@ SRC_URI="https://github.com/zeromq/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0/4"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc64 ~riscv x86"
-IUSE="curl drafts http-client http-server lz4 nss static-libs systemd +uuid"
+IUSE="curl drafts http-client http-server lz4 nss static-libs systemd test +uuid"
+RESTRICT="!test? ( test )"
BDEPEND="app-text/asciidoc
app-text/xmlto
@@ -41,9 +42,13 @@ src_configure() {
--with-libsystemd=$(usex systemd)
--with-liblz4=$(usex lz4)
--with-nss=$(usex nss)
+ $(use_enable test czmq_selftest)
)
- econf "${myeconfargs[@]}"
+ # Force bash for configure until the fixes for bug #923922 land in a release
+ # https://github.com/zeromq/zproject/pull/1336
+ # https://github.com/zeromq/libzmq/pull/4651
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_install() {