summaryrefslogtreecommitdiff
path: root/net-irc/xaric/xaric-0.13.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/xaric/xaric-0.13.6.ebuild')
-rw-r--r--net-irc/xaric/xaric-0.13.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-irc/xaric/xaric-0.13.6.ebuild b/net-irc/xaric/xaric-0.13.6.ebuild
new file mode 100644
index 000000000000..07620a7f34e0
--- /dev/null
+++ b/net-irc/xaric/xaric-0.13.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="An IRC client similar to ircII, BitchX, or ircII EPIC"
+HOMEPAGE="http://xaric.org/"
+SRC_URI="http://xaric.org/software/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon xaric.xpm
+}