summaryrefslogtreecommitdiff
path: root/net-irc/weechat/weechat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 024f0d1b0d09..9ff15b1d86c5 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -135,6 +135,14 @@ src_configure() {
-DENABLE_XFER=$(usex xfer)
)
+ if use python; then
+ python_export PYTHON_LIBPATH
+ mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_LIBRARY="${PYTHON_LIBPATH}"
+ )
+ fi
+
cmake-utils_src_configure
}