summaryrefslogtreecommitdiff
path: root/net-irc/sic/sic-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/sic/sic-1.2.ebuild')
-rw-r--r--net-irc/sic/sic-1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/sic/sic-1.2.ebuild b/net-irc/sic/sic-1.2.ebuild
new file mode 100644
index 000000000000..67faf284d4f9
--- /dev/null
+++ b/net-irc/sic/sic-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="https://tools.suckless.org/sic"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS = -s/LDFLAGS +=/" \
+ -e "/^LIBS =/d" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+
+ # enable verbose build
+ sed -i 's/@${CC}/${CC}/' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}