summaryrefslogtreecommitdiff
path: root/net-irc/rhapsody/rhapsody-0.28b.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/rhapsody/rhapsody-0.28b.ebuild')
-rw-r--r--net-irc/rhapsody/rhapsody-0.28b.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/rhapsody/rhapsody-0.28b.ebuild b/net-irc/rhapsody/rhapsody-0.28b.ebuild
new file mode 100644
index 000000000000..51a622f12e21
--- /dev/null
+++ b/net-irc/rhapsody/rhapsody-0.28b.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="IRC client intended to be displayed on a text console"
+HOMEPAGE="http://rhapsody.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-uclibc.patch
+}
+
+src_compile() {
+ ./configure -i /usr/share/rhapsody || die "configure failed"
+ emake CC="$(tc-getCC)" LOCALFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin rhapsody || die "dobin failed"
+
+ insinto /usr/share/rhapsody/help
+ doins help/*.hlp || die "doins failed"
+
+ dodoc docs/CHANGELOG || die "dodoc failed"
+}