summaryrefslogtreecommitdiff
path: root/net-irc/redirbot/redirbot-0.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/redirbot/redirbot-0.0.5-r1.ebuild')
-rw-r--r--net-irc/redirbot/redirbot-0.0.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/redirbot/redirbot-0.0.5-r1.ebuild b/net-irc/redirbot/redirbot-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..614b3605678a
--- /dev/null
+++ b/net-irc/redirbot/redirbot-0.0.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DOCS=( ChangeLog README.rst )
+
+inherit distutils-r1
+
+DESCRIPTION="IRCBot, telling people they should contact you on different nickname"
+HOMEPAGE="https://github.com/yaccz/redirbot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ ( >=dev-python/twisted-core-11.1.0[${PYTHON_USEDEP}]
+ dev-python/twisted-words[${PYTHON_USEDEP}]
+ )
+ )
+"
+RDEPEND="${DEPEND}"