summaryrefslogtreecommitdiff
path: root/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild')
-rw-r--r--net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild b/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
index 9d5251d93d3f..c176e4cd985f 100644
--- a/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
+++ b/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,10 +19,6 @@ IUSE="spell aspell timezone translator shorturl nls figlet
ILINGUAS="zh_CN zh_TW ru nl de fi fr it ja"
RUBY_S="${PN}-${GITHUB_COMMIT}"
-for lang in $ILINGUAS; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
RUBY_PATCHES=( rbot-rakefile-gettext.patch )
RDEPEND+="
@@ -128,7 +124,7 @@ all_ruby_compile() {
# need to add them later.
if use nls; then
strip-linguas ${ILINGUAS}
- if [[ -n ${LINGUAS} ]]; then
+ if [[ -n ${LINGUAS+set} ]]; then
# As the the language name used by the rbot data files does
# not correspond to the ISO codes we usually use for LINGUAS,
# the following list of local varables will work as a
@@ -143,7 +139,7 @@ all_ruby_compile() {
local lang_rbot_ja="japanese"
for lang in ${ILINGUAS}; do
- use linguas_${lang} && continue
+ has ${lang} ${LINGUAS} && continue
lang_varname="lang_rbot_${lang}"
lang_rbot=${!lang_varname}