summaryrefslogtreecommitdiff
path: root/net-irc/muh/muh-2.2a-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/muh/muh-2.2a-r1.ebuild')
-rw-r--r--net-irc/muh/muh-2.2a-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/muh/muh-2.2a-r1.ebuild b/net-irc/muh/muh-2.2a-r1.ebuild
new file mode 100644
index 000000000000..c5c9dc85ad91
--- /dev/null
+++ b/net-irc/muh/muh-2.2a-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Persistent IRC bouncer"
+HOMEPAGE="http://mind.riot.org/muh/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ipv6"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --datadir=/usr/share/muh $(use_enable ipv6)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "You'll need to configure muh before running it."
+ elog "Put your config in ~/.muh/muhrc"
+ elog "A sample config is /usr/share/muh/muhrc"
+ elog "For more information, see the documentation."
+ elog
+}