summaryrefslogtreecommitdiff
path: root/net-irc/ii/ii-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ii/ii-9999.ebuild')
-rw-r--r--net-irc/ii/ii-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/ii/ii-9999.ebuild b/net-irc/ii/ii-9999.ebuild
new file mode 100644
index 000000000000..0cb5a9d7e15b
--- /dev/null
+++ b/net-irc/ii/ii-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="https://tools.suckless.org/ii/"
+EGIT_REPO_URI="https://git.suckless.org/ii"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
+ -e '/^CC/d' \
+ -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ config.mk || die
+ sed -i \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ dodoc CHANGES FAQ README
+ doman *.1
+}