summaryrefslogtreecommitdiff
path: root/net-irc/hexchat/hexchat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index be5bee2dfbb2..1958b10d37e7 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-LUA_COMPAT=( lua5-{1..4} luajit )
-PYTHON_COMPAT=( python3_{10..11} )
+LUA_COMPAT=( lua5-{1..5} luajit )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit flag-o-matic lua-single meson mono-env python-single-r1 xdg
+inherit lua-single meson mono-env python-single-r1 xdg
DESCRIPTION="Graphical IRC client based on XChat"
HOMEPAGE="https://hexchat.github.io/"
@@ -17,7 +17,7 @@ if [[ "${PV}" == "9999" ]] ; then
SRC_URI=""
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
- SRC_URI="https://dl.hexchat.net/${PN}/${P}.tar.xz"
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
fi
@@ -60,9 +60,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
- dev-util/glib-utils
app-arch/xz-utils
app-text/iso-codes
+ dev-util/glib-utils
sys-devel/gettext
virtual/pkgconfig
"
@@ -77,9 +77,6 @@ pkg_setup() {
}
src_configure() {
- # LTO type mismatch, https://bugs.gentoo.org/861458
- filter-lto
-
local emesonargs=(
-Ddbus-service-use-appid=false
-Dinstall-appdata=false