summaryrefslogtreecommitdiff
path: root/net-irc/eggdrop/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/eggdrop/files')
-rw-r--r--net-irc/eggdrop/files/eggdrop-1.8.4-fix-array-bounds-warning.patch24
-rw-r--r--net-irc/eggdrop/files/eggdrop-1.8.4-respect-ldflags.patch39
2 files changed, 63 insertions, 0 deletions
diff --git a/net-irc/eggdrop/files/eggdrop-1.8.4-fix-array-bounds-warning.patch b/net-irc/eggdrop/files/eggdrop-1.8.4-fix-array-bounds-warning.patch
new file mode 100644
index 000000000000..7c6c2d6dae69
--- /dev/null
+++ b/net-irc/eggdrop/files/eggdrop-1.8.4-fix-array-bounds-warning.patch
@@ -0,0 +1,24 @@
+diff --git a/src/flags.c b/src/flags.c
+index 8cecd2898..3f0a7ea32 100644
+--- a/src/flags.c
++++ b/src/flags.c
+@@ -403,7 +403,10 @@ void break_down_flags(const char *string, struct flag_record *plus,
+ which = plus;
+ mode++;
+ if ((mode == 2) && !(flags & (FR_CHAN | FR_BOT)))
+- string = "";
++ goto breakout; /* string = ""; does not work here because we need to
++ break out of while() / nested switch(), see
++ "string++;" below and string = "\0"; is worse than
++ goto */
+ else if (mode == 3)
+ mode = 1;
+ break;
+@@ -447,6 +450,7 @@ void break_down_flags(const char *string, struct flag_record *plus,
+ }
+ string++;
+ }
++breakout:
+ for (which = plus; which; which = (which == plus ? minus : 0)) {
+ which->global &=USER_VALID;
+
diff --git a/net-irc/eggdrop/files/eggdrop-1.8.4-respect-ldflags.patch b/net-irc/eggdrop/files/eggdrop-1.8.4-respect-ldflags.patch
new file mode 100644
index 000000000000..e41dbd664c51
--- /dev/null
+++ b/net-irc/eggdrop/files/eggdrop-1.8.4-respect-ldflags.patch
@@ -0,0 +1,39 @@
+From 36f2df10c6c39290f6896f9ad5eb9d1419a1abe3 Mon Sep 17 00:00:00 2001
+From: Michael Ortmann <41313082+michaelortmann@users.noreply.github.com>
+Date: Tue, 26 May 2020 01:08:03 +0200
+Subject: [PATCH] Respect LDFLAGS
+
+---
+ src/Makefile.in | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 6757bbc8c..c9605a049 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -16,6 +16,7 @@ LD = @CC@
+ STRIP = @STRIP@
+ CFLAGS = @CFLAGS@ -I.. -I$(top_srcdir) @SSL_INCLUDES@ @DEFS@ $(CFLGS)
+ CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
+
+ eggdrop_objs = bg.o botcmd.o botmsg.o botnet.o chanprog.o cmds.o dcc.o \
+ dccutil.o dns.o flags.o language.o match.o main.o mem.o misc.o misc_file.o \
+@@ -41,7 +42,7 @@ linkstart:
+ touch mod/mod.xlibs
+
+ link:
+- $(LD) $(CFLAGS) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
++ $(LD) $(CFLAGS) $(LDFLAGS) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
+
+ linkfinish:
+ @$(STRIP) ../$(EGGEXEC) && \
+@@ -63,7 +64,7 @@ clean:
+ main.o:
+ $(CC) $(CFLAGS) $(CPPFLAGS) \
+ '-DCCFLAGS="$(CC) $(CFLAGS) $(CPPFLAGS)"' \
+- '-DLDFLAGS="$(LD)"' \
++ '-DLDFLAGS="$(LD) $(LDFLAGS)"' \
+ '-DSTRIPFLAGS="$(STRIP)"' -c $(srcdir)/main.c
+
+ compatibility: